aboutsummaryrefslogtreecommitdiff
path: root/graphics/gts
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 15:56:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-23 15:56:09 +0000
commit380849a3b1263430a88d169697f5a3925c28f7e0 (patch)
tree59e5293a50e813c1a44a28769fb49289f5aff616 /graphics/gts
parent5888a6393c7213692e08cab93a264d8ff9982522 (diff)
downloadports-380849a3b1263430a88d169697f5a3925c28f7e0.tar.gz
ports-380849a3b1263430a88d169697f5a3925c28f7e0.zip
add gts 0.6.0
GNU Triangulated Surface Library
Notes
Notes: svn path=/head/; revision=61822
Diffstat (limited to 'graphics/gts')
-rw-r--r--graphics/gts/Makefile31
-rw-r--r--graphics/gts/distinfo1
-rw-r--r--graphics/gts/pkg-comment1
-rw-r--r--graphics/gts/pkg-descr26
-rw-r--r--graphics/gts/pkg-plist71
5 files changed, 130 insertions, 0 deletions
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
new file mode 100644
index 000000000000..187fbd2d3182
--- /dev/null
+++ b/graphics/gts/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: gts
+# Date created: Jun 23, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gts
+PORTVERSION= 0.6.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_LIBTOOL= yes
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gts/distinfo b/graphics/gts/distinfo
new file mode 100644
index 000000000000..9f2ca59ae46e
--- /dev/null
+++ b/graphics/gts/distinfo
@@ -0,0 +1 @@
+MD5 (gts-0.6.0.tar.gz) = 91bd70049dac7f604d73f11fe513045f
diff --git a/graphics/gts/pkg-comment b/graphics/gts/pkg-comment
new file mode 100644
index 000000000000..bd4af4fffb38
--- /dev/null
+++ b/graphics/gts/pkg-comment
@@ -0,0 +1 @@
+GNU Triangulated Surface Library
diff --git a/graphics/gts/pkg-descr b/graphics/gts/pkg-descr
new file mode 100644
index 000000000000..38bd43fddd2e
--- /dev/null
+++ b/graphics/gts/pkg-descr
@@ -0,0 +1,26 @@
+GTS stands for the GNU Triangulated Surface Library. It is an Open Source
+Free Software Library intended to provide a set of useful functions to deal
+with 3D surfaces meshed with interconnected triangles.
+
+The code is written entirely in C with an object-oriented approach based
+mostly on the design of GTK+. Careful attention is paid to performance related
+issues as the initial goal of GTS is to provide a simple and efficient library
+to scientists dealing with 3D computational surface meshes.
+
+A brief summary of its main features:
+ - Simple object-oriented structure giving easy access to topological
+ properties.
+ - 2D dynamic Delaunay and constrained Delaunay triangulations.
+ - Robust geometric predicates (orientation, in circle) using fast adaptive
+ floating point arithmetic.
+ - Robust set operations on surfaces (union, intersection, difference).
+ - Surface refinement and coarsening (multiresolution models).
+ - Dynamic view-independent continuous level-of-detail.
+ - Preliminary support for view-dependent level-of-detail.
+ - Bounding-boxes trees and Kd-trees for efficient point location and
+ collision/intersection detection.
+ - Graph operations: traversal, graph partitioning.
+ - Metric operations (area, volume, curvature ...).
+ - Triangle strips generation for fast rendering.
+
+WWW: http://gts.sourceforge.net/
diff --git a/graphics/gts/pkg-plist b/graphics/gts/pkg-plist
new file mode 100644
index 000000000000..57f93a70a157
--- /dev/null
+++ b/graphics/gts/pkg-plist
@@ -0,0 +1,71 @@
+bin/gts-config
+bin/gts2oogl
+bin/gtscompare
+bin/gtscheck
+bin/gtstemplate
+bin/transform
+include/gts.h
+include/gtsconfig.h
+lib/libgts-0.6.so.0
+lib/libgts.a
+lib/libgts.so
+share/aclocal/gts.m4
+%%PORTDOCS%%share/doc/gts/book1.html
+%%PORTDOCS%%share/doc/gts/c10143.html
+%%PORTDOCS%%share/doc/gts/c10165.html
+%%PORTDOCS%%share/doc/gts/c10178.html
+%%PORTDOCS%%share/doc/gts/c11561.html
+%%PORTDOCS%%share/doc/gts/c12040.html
+%%PORTDOCS%%share/doc/gts/c12337.html
+%%PORTDOCS%%share/doc/gts/c12388.html
+%%PORTDOCS%%share/doc/gts/c12401.html
+%%PORTDOCS%%share/doc/gts/c13060.html
+%%PORTDOCS%%share/doc/gts/c13676.html
+%%PORTDOCS%%share/doc/gts/c13971.html
+%%PORTDOCS%%share/doc/gts/c14022.html
+%%PORTDOCS%%share/doc/gts/c14035.html
+%%PORTDOCS%%share/doc/gts/c1865.html
+%%PORTDOCS%%share/doc/gts/c1908.html
+%%PORTDOCS%%share/doc/gts/c2195.html
+%%PORTDOCS%%share/doc/gts/c2230.html
+%%PORTDOCS%%share/doc/gts/c4.html
+%%PORTDOCS%%share/doc/gts/c8089.html
+%%PORTDOCS%%share/doc/gts/c8393.html
+%%PORTDOCS%%share/doc/gts/c8683.html
+%%PORTDOCS%%share/doc/gts/c8718.html
+%%PORTDOCS%%share/doc/gts/c9511.html
+%%PORTDOCS%%share/doc/gts/c9853.html
+%%PORTDOCS%%share/doc/gts/dummy.html
+%%PORTDOCS%%share/doc/gts/gts-binary-heaps.html
+%%PORTDOCS%%share/doc/gts/gts-boolean-operations.html
+%%PORTDOCS%%share/doc/gts/gts-bounding-boxes-trees.html
+%%PORTDOCS%%share/doc/gts/gts-containee-classes.html
+%%PORTDOCS%%share/doc/gts/gts-container-classes.html
+%%PORTDOCS%%share/doc/gts/gts-delaunay-and-constrained-delaunay-triangulations.html
+%%PORTDOCS%%share/doc/gts/gts-edges.html
+%%PORTDOCS%%share/doc/gts/gts-extended-binary-heaps.html
+%%PORTDOCS%%share/doc/gts/gts-faces.html
+%%PORTDOCS%%share/doc/gts/gts-first-in-first-out-heaps.html
+%%PORTDOCS%%share/doc/gts/gts-graph-class.html
+%%PORTDOCS%%share/doc/gts/gts-graph-partitioning.html
+%%PORTDOCS%%share/doc/gts/gts-hierarchical-surfaces.html
+%%PORTDOCS%%share/doc/gts/gts-hierarchical-vertex-split.html
+%%PORTDOCS%%share/doc/gts/gts-isosurfaces-from-3d-functions.html
+%%PORTDOCS%%share/doc/gts/gts-kd-trees.html
+%%PORTDOCS%%share/doc/gts/gts-miscellaneous-macros-and-functions.html
+%%PORTDOCS%%share/doc/gts/gts-object-class.html
+%%PORTDOCS%%share/doc/gts/gts-out-of-core-simplification.html
+%%PORTDOCS%%share/doc/gts/gts-points.html
+%%PORTDOCS%%share/doc/gts/gts-progressive-graph.html
+%%PORTDOCS%%share/doc/gts/gts-progressive-surfaces.html
+%%PORTDOCS%%share/doc/gts/gts-segments.html
+%%PORTDOCS%%share/doc/gts/gts-simple-statistics.html
+%%PORTDOCS%%share/doc/gts/gts-surface-simplification-and-refinement.html
+%%PORTDOCS%%share/doc/gts/gts-surfaces.html
+%%PORTDOCS%%share/doc/gts/gts-triangles.html
+%%PORTDOCS%%share/doc/gts/gts-vectors-and-matrices.html
+%%PORTDOCS%%share/doc/gts/gts-vertex-split.html
+%%PORTDOCS%%share/doc/gts/gts-vertices.html
+%%PORTDOCS%%share/doc/gts/gts-weighted-graph.html
+%%PORTDOCS%%share/doc/gts/index.sgml
+%%PORTDOCS%%@dirrm share/doc/gts