aboutsummaryrefslogtreecommitdiff
path: root/graphics/gts
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 08:31:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 08:31:29 +0000
commitcda59ea3e25f7188d5070e5a9ee5d0af11627402 (patch)
tree933a79805e8e74784ee3f4b8399955b260e7b423 /graphics/gts
parent381250fd12c0b35545d8073b16e86cf0e561e9be (diff)
downloadports-cda59ea3e25f7188d5070e5a9ee5d0af11627402.tar.gz
ports-cda59ea3e25f7188d5070e5a9ee5d0af11627402.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=317482
Diffstat (limited to 'graphics/gts')
-rw-r--r--graphics/gts/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index 1b09eb1a10e9..abb2a49442d2 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: gts
-# Date created: Jun 23, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= gts
PORTVERSION= 0.7.6
@@ -19,14 +14,15 @@ USE_GNOME= glib20 pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-OPTIONS= NETPBM "Build with libnetpbm support" off
+OPTIONS_DEFINE= NETPBM
+NETPBM_DESC= Build with libnetpbm support
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_NETPBM)
+.if ${PORT_OPTIONS:MNETPBM}
LIB_DEPENDS+= netpbm.1:${PORTSDIR}/graphics/netpbm
PLIST_SUB= NETPBM=""
.else
@@ -34,7 +30,7 @@ PLIST_SUB= NETPBM="@comment "
.endif
post-extract:
-.if !defined(WITH_NETPBM)
+.if ! ${PORT_OPTIONS:MNETPBM}
@${REINPLACE_CMD} -e 's|netpbm="true"|netpbm="false"|' \
${WRKSRC}/configure
.endif
@@ -43,4 +39,4 @@ post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-release \$$(LT_RELEASE)||g ; s|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>