aboutsummaryrefslogtreecommitdiff
path: root/graphics/gview/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-03 04:21:33 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-03 04:21:33 +0000
commit4ddc7c84a45b7f1ed1b4063d605c2235bbc6e1d5 (patch)
tree2ce51558cc0842a3fc187778d153cbeba5a67b21 /graphics/gview/Makefile
parenteedf966f0acc8e02fc9c12bca5bd2e495a96dad4 (diff)
Notes
Diffstat (limited to 'graphics/gview/Makefile')
-rw-r--r--graphics/gview/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/gview/Makefile b/graphics/gview/Makefile
new file mode 100644
index 000000000000..3e2c291c5d8b
--- /dev/null
+++ b/graphics/gview/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gview
+# Version required: 0.1.4
+# Date created: 30 April 1999
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= gview-0.1.4
+CATEGORIES= graphics
+MASTER_SITES= http://www.geocities.com/ResearchTriangle/Facility/1468/sg/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= gdk_imlib:${PORTSDIR}/graphics/imlib \
+ gdk12:${PORTSDIR}/x11-toolkits/gtk12 \
+ glib12:${PORTSDIR}/devel/glib12 \
+ gmodule12:${PORTSDIR}/devel/glib12 \
+ gtk12:${PORTSDIR}/x11-toolkits/gtk12 \
+ intl:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/gview
+.for file in AUTHORS BUGS COPYING ChangeLog NEWS README TODO
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/gview
+.endfor
+.endif
+
+.include <bsd.port.mk>