aboutsummaryrefslogtreecommitdiff
path: root/graphics/heimer
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-02-20 17:49:52 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-02-20 17:49:52 +0000
commit8468ba6cf092a8002cd16e4780a39b9a3834af66 (patch)
tree39a0dc8992da4083c66c9971f920be63c08ab3ae /graphics/heimer
parentfe6b9a1274dc2dcef284912c583737c54a6dec5c (diff)
downloadports-8468ba6cf092a8002cd16e4780a39b9a3834af66.tar.gz
ports-8468ba6cf092a8002cd16e4780a39b9a3834af66.zip
New port: graphics/heimer
Heimer is a desktop application for creating mind maps and other suitable diagrams. It is written in Qt. Features: - Easy-to-use UI - Very fast - Zoom in/out/fit - Zoom with mouse wheel - Save/load in XML-based .ALZ-files - Export to PNG images - Quickly add node text and edge labels - Nice animations - Full undo/redo - Adjustable grid - Translations in English, Finnish, French, Italian - Forever 100% free WWW: https://github.com/juzzlin/Heimer
Notes
Notes: svn path=/head/; revision=526574
Diffstat (limited to 'graphics/heimer')
-rw-r--r--graphics/heimer/Makefile31
-rw-r--r--graphics/heimer/distinfo3
-rw-r--r--graphics/heimer/pkg-descr18
-rw-r--r--graphics/heimer/pkg-plist8
4 files changed, 60 insertions, 0 deletions
diff --git a/graphics/heimer/Makefile b/graphics/heimer/Makefile
new file mode 100644
index 000000000000..6356b22c78c4
--- /dev/null
+++ b/graphics/heimer/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= heimer
+DISTVERSION= 1.15.0
+CATEGORIES= graphics
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Simple mind map, diagram, and note-taking tool
+
+LICENSE= CC-BY-SA-3.0 GPLv3+
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING
+
+USES= cmake compiler:c++11-lang qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= juzzlin
+GH_PROJECT= Heimer
+USE_QT= core gui widgets xml buildtools_build linguisttools_build \
+ qmake_build testlib_build
+TEST_TARGET= test
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/heimer
+
+post-install-EXAMPLES-on:
+ cd ${WRKSRC}/examples && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/graphics/heimer/distinfo b/graphics/heimer/distinfo
new file mode 100644
index 000000000000..853623fae963
--- /dev/null
+++ b/graphics/heimer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582218820
+SHA256 (juzzlin-Heimer-1.15.0_GH0.tar.gz) = 16c35f6e742868b83db1ac94959252b0d517a9fff6c4d2821cf8495b6285f553
+SIZE (juzzlin-Heimer-1.15.0_GH0.tar.gz) = 851155
diff --git a/graphics/heimer/pkg-descr b/graphics/heimer/pkg-descr
new file mode 100644
index 000000000000..41d0f53b4a87
--- /dev/null
+++ b/graphics/heimer/pkg-descr
@@ -0,0 +1,18 @@
+Heimer is a desktop application for creating mind maps and other
+suitable diagrams. It is written in Qt.
+
+Features:
+- Easy-to-use UI
+- Very fast
+- Zoom in/out/fit
+- Zoom with mouse wheel
+- Save/load in XML-based .ALZ-files
+- Export to PNG images
+- Quickly add node text and edge labels
+- Nice animations
+- Full undo/redo
+- Adjustable grid
+- Translations in English, Finnish, French, Italian
+- Forever 100% free
+
+WWW: https://github.com/juzzlin/Heimer
diff --git a/graphics/heimer/pkg-plist b/graphics/heimer/pkg-plist
new file mode 100644
index 000000000000..51a77e18427c
--- /dev/null
+++ b/graphics/heimer/pkg-plist
@@ -0,0 +1,8 @@
+bin/heimer
+share/applications/heimer.desktop
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Company.alz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Family.alz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Heimer.alz
+share/icons/hicolor/64x64/apps/heimer.png
+share/metainfo/heimer.appdata.xml
+share/pixmaps/heimer.png