aboutsummaryrefslogtreecommitdiff
path: root/graphics/hppsmtools
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-10-07 03:26:00 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-10-07 03:26:00 +0000
commit1322d3871646f2a643b51ca3d13e4d846886b3d2 (patch)
tree7357b0d86d1fa52cd97c8e8833c40b81b12f8b78 /graphics/hppsmtools
parent3ca38befb08d8da972ebc7db3728e087b0589766 (diff)
downloadports-1322d3871646f2a643b51ca3d13e4d846886b3d2.tar.gz
ports-1322d3871646f2a643b51ca3d13e4d846886b3d2.zip
hppsmtools is a program for communicating with the HP PhotoSmart
C5340A and Konica Q-EZ digital cameras. You can retrieve, get an index of, delete and shoot pictures. PR: 13533 Submitted by: Anders Nordby <anders@fix.no>
Notes
Notes: svn path=/head/; revision=22213
Diffstat (limited to 'graphics/hppsmtools')
-rw-r--r--graphics/hppsmtools/Makefile29
-rw-r--r--graphics/hppsmtools/distinfo1
-rw-r--r--graphics/hppsmtools/files/patch-aa16
-rw-r--r--graphics/hppsmtools/pkg-comment1
-rw-r--r--graphics/hppsmtools/pkg-descr6
-rw-r--r--graphics/hppsmtools/pkg-plist6
6 files changed, 59 insertions, 0 deletions
diff --git a/graphics/hppsmtools/Makefile b/graphics/hppsmtools/Makefile
new file mode 100644
index 000000000000..338004f06777
--- /dev/null
+++ b/graphics/hppsmtools/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hppsmtools
+# Version required: 0.3
+# Date created: 2 September 1999
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+DISTNAME= hppsmtools-0.3
+CATEGORIES= graphics
+MASTER_SITES= http://unimut.fsk.uni-heidelberg.de/unimut/photosmart/ \
+ http://www.freenix.no/~anders/ \
+ ftp://totem.fix.no/pub/mirrors/misc/
+
+MAINTAINER= anders@fix.no
+
+ALL_TARGET=
+
+do-install:
+ @${RM} -f ${PREFIX}/bin/psmget ${PREFIX}/bin/psmdir
+ @${RM} -f ${PREFIX}/bin/psmdel ${PREFIX}/bin/psmsho
+ @${INSTALL_PROGRAM} ${WRKSRC}/psmget ${PREFIX}/bin/
+ @${LN} ${PREFIX}/bin/psmget ${PREFIX}/bin/psmdir
+ @${LN} ${PREFIX}/bin/psmget ${PREFIX}/bin/psmdel
+ @${LN} ${PREFIX}/bin/psmget ${PREFIX}/bin/psmsho
+ @${INSTALL} -d -m 0755 ${PREFIX}/share/doc/hppsmtools
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/hppsmtools/
+
+.include <bsd.port.mk>
diff --git a/graphics/hppsmtools/distinfo b/graphics/hppsmtools/distinfo
new file mode 100644
index 000000000000..e00efb8327c6
--- /dev/null
+++ b/graphics/hppsmtools/distinfo
@@ -0,0 +1 @@
+MD5 (hppsmtools-0.3.tar.gz) = 55a5a81016c7f8f1f257dd34322d6936
diff --git a/graphics/hppsmtools/files/patch-aa b/graphics/hppsmtools/files/patch-aa
new file mode 100644
index 000000000000..ef8000e5e6d5
--- /dev/null
+++ b/graphics/hppsmtools/files/patch-aa
@@ -0,0 +1,16 @@
+*** psmget.c.orig Wed Sep 1 23:04:53 1999
+--- psmget.c Wed Sep 1 23:06:41 1999
+***************
+*** 13,23 ****
+ #include <sys/poll.h>
+ #include <sys/ioctl.h>
+
+- #ifdef PSM_GLIBC
+ #include <errno.h>
+- #include <termbits.h>
+ #include <termios.h>
+- #endif
+
+ typedef unsigned char uchar;
+
+--- 13,20 ----
diff --git a/graphics/hppsmtools/pkg-comment b/graphics/hppsmtools/pkg-comment
new file mode 100644
index 000000000000..3e7eb2b42f24
--- /dev/null
+++ b/graphics/hppsmtools/pkg-comment
@@ -0,0 +1 @@
+Tool for HP PhotoSmart C5340A & Konica Q-Konica Q-EZ digital cameras
diff --git a/graphics/hppsmtools/pkg-descr b/graphics/hppsmtools/pkg-descr
new file mode 100644
index 000000000000..effdb7fd2fe3
--- /dev/null
+++ b/graphics/hppsmtools/pkg-descr
@@ -0,0 +1,6 @@
+hppsmtools is a program for communicating with the HP PhotoSmart
+C5340A and Konica Q-EZ digital cameras. You can retrive, have an
+index of, delete and shoot pictures.
+
+Author: msdemlei@tucana.ari.uni-heidelberg.de
+WWW: http://unimut.fsk.uni-heidelberg.de/unimut/photosmart/
diff --git a/graphics/hppsmtools/pkg-plist b/graphics/hppsmtools/pkg-plist
new file mode 100644
index 000000000000..90c9462528ec
--- /dev/null
+++ b/graphics/hppsmtools/pkg-plist
@@ -0,0 +1,6 @@
+bin/psmget
+bin/psmdir
+bin/psmdel
+bin/psmsho
+share/doc/hppsmtools/README
+@dirrm share/doc/hppsmtools