aboutsummaryrefslogtreecommitdiff
path: root/graphics/hppsmtools
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-21 20:42:02 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-21 20:42:02 +0000
commit3635c095b334791511744f87fcee9c2c11a85a3f (patch)
tree324d6f9a21bf5c02a5a28e61bdd83c201683de8d /graphics/hppsmtools
parente9d216fb2c63ab5716ac2a3910392c3ce44ce087 (diff)
downloadports-3635c095b334791511744f87fcee9c2c11a85a3f.tar.gz
ports-3635c095b334791511744f87fcee9c2c11a85a3f.zip
Stage support
Notes
Notes: svn path=/head/; revision=340656
Diffstat (limited to 'graphics/hppsmtools')
-rw-r--r--graphics/hppsmtools/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/hppsmtools/Makefile b/graphics/hppsmtools/Makefile
index bd68f8624b45..8e2e94261599 100644
--- a/graphics/hppsmtools/Makefile
+++ b/graphics/hppsmtools/Makefile
@@ -12,25 +12,22 @@ COMMENT= Tool for HP PhotoSmart C5340A & Konica Q-EZ digital cameras
LICENSE= GPLv2
-PORTDOCS= README changes.txt
PLIST_FILES= bin/psmdel bin/psmdir bin/psmget bin/psmsho
+PORTDOCS= README changes.txt
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|^CC=|#CC=|g ; \
s|-Wall -pedantic|$$(CFLAGS)|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e '/typedef unsigned char/d' ${WRKSRC}/exif.h
@${REINPLACE_CMD} -e '/<malloc.h>/d' ${WRKSRC}/psm*.c
-.include <bsd.port.options.mk>
-
do-install:
.for file in psmdel psmdir psmget psmsho
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>