aboutsummaryrefslogtreecommitdiff
path: root/graphics/hppsmtools
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-04-21 15:24:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-04-21 15:24:30 +0000
commit8124ea5aab4e3b4249bde6a2e5d2e738adc81f31 (patch)
treebbab38f251e8630687dacfef83de1afee28aa99e /graphics/hppsmtools
parentb5a0d3fe9226826fe3f6c0f82cdd3b99f53468fe (diff)
downloadports-8124ea5aab4e3b4249bde6a2e5d2e738adc81f31.tar.gz
ports-8124ea5aab4e3b4249bde6a2e5d2e738adc81f31.zip
Update to version 1.1
PR: ports/80205 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=133863
Diffstat (limited to 'graphics/hppsmtools')
-rw-r--r--graphics/hppsmtools/Makefile14
-rw-r--r--graphics/hppsmtools/distinfo4
-rw-r--r--graphics/hppsmtools/files/patch-aa12
-rw-r--r--graphics/hppsmtools/files/patch-exif.h11
-rw-r--r--graphics/hppsmtools/files/patch-psmdel.c10
-rw-r--r--graphics/hppsmtools/files/patch-psmdir.c10
-rw-r--r--graphics/hppsmtools/pkg-plist6
7 files changed, 15 insertions, 52 deletions
diff --git a/graphics/hppsmtools/Makefile b/graphics/hppsmtools/Makefile
index 34c1d86a827e..10ca0ae6cabd 100644
--- a/graphics/hppsmtools/Makefile
+++ b/graphics/hppsmtools/Makefile
@@ -6,13 +6,25 @@
#
PORTNAME= hppsmtools
-PORTVERSION= 1.02
+PORTVERSION= 1.1
+PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://unimut.fsk.uni-heidelberg.de/demi/photosmart/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for HP PhotoSmart C5340A & Konica Q-EZ digital cameras
+USE_REINPLACE= yes
+
+PORTDOCS= README
+PLIST_FILES= bin/psmdel bin/psmdir bin/psmget bin/psmsho
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CC=|#CC=|g ; \
+ s|-Wall -pedantic|$$(CFLAGS)|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/typedef unsigned char/d' ${WRKSRC}/exif.h
+ @${REINPLACE_CMD} -e '/<malloc.h>/d' ${WRKSRC}/psm*.c
+
do-install:
.for file in psmdel psmdir psmget psmsho
${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
diff --git a/graphics/hppsmtools/distinfo b/graphics/hppsmtools/distinfo
index 78fdad09812f..0df4901201fb 100644
--- a/graphics/hppsmtools/distinfo
+++ b/graphics/hppsmtools/distinfo
@@ -1,2 +1,2 @@
-MD5 (hppsmtools-1.02.tar.gz) = b6d49af2321a06ff8cb0821c5deac3fc
-SIZE (hppsmtools-1.02.tar.gz) = 25887
+MD5 (hppsmtools-1.1.tar.gz) = e3b490ff97ce4f5bd9a3974193b926bb
+SIZE (hppsmtools-1.1.tar.gz) = 27048
diff --git a/graphics/hppsmtools/files/patch-aa b/graphics/hppsmtools/files/patch-aa
deleted file mode 100644
index d939436777fd..000000000000
--- a/graphics/hppsmtools/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.orig Wed Mar 1 15:23:12 2000
-+++ Makefile Sun Aug 26 12:33:29 2001
-@@ -6,8 +6,7 @@
- # Set this to your liking
- PREFIX=/usr/local
-
--COPTS=$(ADDIT_DEFS) -Wall -pedantic
--CC=gcc
-+COPTS=$(ADDIT_DEFS) $(CFLAGS)
-
- FILES= psm.h psm.c \
- exif.h exifparse.c \
diff --git a/graphics/hppsmtools/files/patch-exif.h b/graphics/hppsmtools/files/patch-exif.h
deleted file mode 100644
index ddbbed86c1df..000000000000
--- a/graphics/hppsmtools/files/patch-exif.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- exif.h.orig Sun Aug 26 12:32:35 2001
-+++ exif.h Sun Aug 26 12:32:44 2001
-@@ -94,8 +94,6 @@
-
- #define EXIF_INVALID_RATIONAL 1e40
-
--typedef unsigned char uint8_t;
--
- /* The next two types are actually private */
- typedef struct
- { int16_t tag;
diff --git a/graphics/hppsmtools/files/patch-psmdel.c b/graphics/hppsmtools/files/patch-psmdel.c
deleted file mode 100644
index 7432fd0e8e57..000000000000
--- a/graphics/hppsmtools/files/patch-psmdel.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- psmdel.c.orig Sun Aug 26 12:29:07 2001
-+++ psmdel.c Sun Aug 26 12:29:11 2001
-@@ -3,7 +3,6 @@
- #include <unistd.h>
- #include <signal.h>
- #include <string.h>
--#include <malloc.h>
- #include "psm.h"
- #include "config.h"
-
diff --git a/graphics/hppsmtools/files/patch-psmdir.c b/graphics/hppsmtools/files/patch-psmdir.c
deleted file mode 100644
index 9bf35b545e58..000000000000
--- a/graphics/hppsmtools/files/patch-psmdir.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- psmdir.c.orig Sun Aug 26 12:29:38 2001
-+++ psmdir.c Sun Aug 26 12:29:44 2001
-@@ -3,7 +3,6 @@
- #include <unistd.h>
- #include <signal.h>
- #include <string.h>
--#include <malloc.h>
- #include <math.h>
- #include "psm.h"
- #include "config.h"
diff --git a/graphics/hppsmtools/pkg-plist b/graphics/hppsmtools/pkg-plist
deleted file mode 100644
index ea70544dfb3b..000000000000
--- a/graphics/hppsmtools/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/psmdel
-bin/psmdir
-bin/psmget
-bin/psmsho
-%%PORTDOCS%%share/doc/hppsmtools/README
-%%PORTDOCS%%@dirrm share/doc/hppsmtools