aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin/Makefile
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2008-01-19 08:31:35 +0000
committerVasil Dimov <vd@FreeBSD.org>2008-01-19 08:31:35 +0000
commit1d5fcf9ea03a67d52e27f6fd0861ceaee23d5c30 (patch)
tree0d4a526c4733245147408ac46cce39747fed4dee /graphics/hugin/Makefile
parenta0544a6584b3e3308b9c0189982b3fb6a571403b (diff)
downloadports-1d5fcf9ea03a67d52e27f6fd0861ceaee23d5c30.tar.gz
ports-1d5fcf9ea03a67d52e27f6fd0861ceaee23d5c30.zip
* Upgrade graphics/hugin from 0.6.1 to 0.7.b4
* Update libpano dependency to libpano13 * Add OPTIONS to depend on enblend, autopano-sift and ptstitcher * Update automake dependency to 1.10 * Get rid of the autotools hack in pre-configure:, not necessary anymore * Sync pkg-plist * Sync the patches in files/
Notes
Notes: svn path=/head/; revision=205823
Diffstat (limited to 'graphics/hugin/Makefile')
-rw-r--r--graphics/hugin/Makefile55
1 files changed, 36 insertions, 19 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 3fb305d8642c..0f17e92f846a 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hugin
-PORTVERSION= 0.6.1
-PORTREVISION= 2
+DISTVERSION= 0.7_beta4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,38 +14,59 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= vd@FreeBSD.org
COMMENT= A GUI for Panorama Tools, to stitch panoramic images
-BUILD_DEPENDS= libpano12>=2.8.4:${PORTSDIR}/graphics/libpano12 \
- vigra-config:${PORTSDIR}/graphics/vigra \
- zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
+# zip is needed for building the help file
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= pano13:${PORTSDIR}/graphics/libpano13 \
+ tiff:${PORTSDIR}/graphics/tiff \
png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
- fftw:${PORTSDIR}/math/fftw \
boost_date_time:${PORTSDIR}/devel/boost
-RUN_DEPENDS= PTOptimizer:${PORTSDIR}/graphics/libpano12 \
- PTStitcher:${PORTSDIR}/graphics/linux-panorama-tools
+
+OPTIONS= ENBLEND "enblend for high quality blending" on \
+ AUTOPANOSIFT "autopano-sift for automatic control points" on \
+ PTSTITCHER "PTStitcher for stitching images" on
USE_BZIP2= yes
-USE_AUTOTOOLS= autoconf:261:env autoheader:261:env aclocal:19:env \
- automake:19:env libtool:15:env
+USE_AUTOTOOLS= autoconf:261:env autoheader:261:env aclocal:110:env \
+ automake:110:env libtool:15:env
IS_INTERACTIVE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} WXRC=${WXRC_CMD}
-CONFIGURE_ARGS+= --with-boost=${LOCALBASE} \
- --disable-desktop
+CONFIGURE_ARGS+=--with-boost=${LOCALBASE}
+# --disable-desktop
USE_GMAKE= yes
USE_ICONV= yes
-USE_WX= 2.6
+USE_WX= 2.6+
WX_CONF_ARGS= absolute
+.if defined(WX_UNICODE)
+CONFIGURE_ARGS+=--with-unicode=yes
+.else
+CONFIGURE_ARGS+=--with-unicode=no
+.endif
+
MAN1= fulla.1
DOCSDIR= ${PREFIX}/share/hugin/xrc/data
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ENBLEND)
+RUN_DEPENDS+= enblend:${PORTSDIR}/graphics/enblend
+.endif
+
+.if defined(WITH_AUTOPANOSIFT)
+RUN_DEPENDS+= autopanog:${PORTSDIR}/graphics/autopano-sift
+.endif
+
+.if defined(WITH_PTSTITCHER)
+RUN_DEPENDS+= PTStitcher:${PORTSDIR}/graphics/linux-panorama-tools
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
@@ -56,9 +76,6 @@ PLIST_SUB+= NLS=""
.endif
pre-configure:
- cd ${WRKSRC} && \
- ${SETENV} ${AUTOTOOLS_ENV} \
- ACLOCAL="${ACLOCAL} -I ${LOCALBASE}/share/aclocal" \
- ./bootstrap
+ cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ./bootstrap
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>