aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-05-04 05:24:35 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-05-04 05:24:35 +0000
commitb45f12fcf3336119dced20929ca66725648aab5c (patch)
treec7f6bc9d251dd2c747740f5b6aa6e0cabb5d489e /graphics/hugin/Makefile
parent653e4173caf7bb3c8fc0fe47225f19c2303ab498 (diff)
downloadports-b45f12fcf3336119dced20929ca66725648aab5c.tar.gz
ports-b45f12fcf3336119dced20929ca66725648aab5c.zip
Notes
Diffstat (limited to 'graphics/hugin/Makefile')
-rw-r--r--graphics/hugin/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index a18026942015..a853f042b7a1 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hugin
PORTVERSION= 2016.2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -27,12 +27,16 @@ RUN_DEPENDS= enblend>=4.1.4:graphics/enblend \
gmake:devel/gmake
USES= cmake compiler:c++11-lib desktop-file-utils \
- gettext jpeg pkgconfig shared-mime-info tar:bzip2
+ gettext jpeg pkgconfig shared-mime-info shebangfix tar:bzip2
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
USE_WX= 3.0+
USE_GL= glew glut
INSTALLS_ICONS= yes
+SHEBANG_FILES= src/hugin_script_interface/hpi.py \
+ src/hugin_script_interface/plugins/*.py \
+ src/hugin_script_interface/plugins-dev/*.py
+
OPTIONS_DEFINE= PANOMATIC AUTOPANOSIFTC PYTHON
OPTIONS_DEFAULT= PANOMATIC AUTOPANOSIFTC PYTHON
OPTIONS_SUB= yes