aboutsummaryrefslogtreecommitdiff
path: root/graphics/icat
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-29 10:19:15 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-29 10:19:15 +0000
commit0188f3e903f5a40900323c9fbaa6bf9637e58027 (patch)
tree2d57f38456ee06002848431d6d4ce29c7bb31d33 /graphics/icat
parent7dd6a4d5e7094eeb5f1bf37472ef0b41ad229fb3 (diff)
downloadports-0188f3e903f5a40900323c9fbaa6bf9637e58027.tar.gz
ports-0188f3e903f5a40900323c9fbaa6bf9637e58027.zip
Add icat, displays images in 256-color capable terminals.
Notes
Notes: svn path=/head/; revision=316793
Diffstat (limited to 'graphics/icat')
-rw-r--r--graphics/icat/Makefile33
-rw-r--r--graphics/icat/distinfo2
-rw-r--r--graphics/icat/files/patch-Makefile24
-rw-r--r--graphics/icat/pkg-descr4
4 files changed, 63 insertions, 0 deletions
diff --git a/graphics/icat/Makefile b/graphics/icat/Makefile
new file mode 100644
index 000000000000..53d8d61f5ee2
--- /dev/null
+++ b/graphics/icat/Makefile
@@ -0,0 +1,33 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= icat
+PORTVERSION= 0.4
+CATEGORIES= graphics
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Displays images in 256-color capable terminals
+
+USE_GMAKE= yes
+USE_DOS2UNIX= Makefile
+USE_EFL= imlib2
+USE_GITHUB= yes
+GH_ACCOUNT= atextor
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= e8bee81
+
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${PORTNAME}-${GH_COMMIT}
+
+PLIST_FILES= bin/icat
+
+CONFLICTS= sleuthkit-[0-9]*
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/icat/distinfo b/graphics/icat/distinfo
new file mode 100644
index 000000000000..e12dc816ef52
--- /dev/null
+++ b/graphics/icat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (icat-0.4.tar.gz) = 887678f5232dda6ede734f0e4d2872b760aa06c7c619b1261e6055ebbee3c0b0
+SIZE (icat-0.4.tar.gz) = 7871
diff --git a/graphics/icat/files/patch-Makefile b/graphics/icat/files/patch-Makefile
new file mode 100644
index 000000000000..2414cf57e660
--- /dev/null
+++ b/graphics/icat/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- ./Makefile.orig 2013-04-29 11:51:10.242627983 +0200
++++ ./Makefile 2013-04-29 11:51:26.370242683 +0200
+@@ -1,16 +1,16 @@
+-GCC=gcc
+-CCFLAGS=-Wall -pedantic -std=c99 -D_BSD_SOURCE
+-LDFLAGS=-lImlib2
++CC?=gcc
++CFLAGS+=-Wall -pedantic -std=c99 -D_BSD_SOURCE
++LDFLAGS+=-lImlib2
+ PROG=icat
+ MODS=icat.o
+
+ all: $(PROG)
+
+ %.o: %.c
+- $(GCC) -c $(CCFLAGS) -o $@ $<
++ $(CC) -c $(CFLAGS) -o $@ $<
+
+ $(PROG): $(MODS)
+- $(GCC) -o $@ $< $(LDFLAGS)
++ $(CC) -o $@ $< $(LDFLAGS)
+
+ clean:
+ -rm -f $(PROG) $(MODS)
diff --git a/graphics/icat/pkg-descr b/graphics/icat/pkg-descr
new file mode 100644
index 000000000000..ae88bab0a9b4
--- /dev/null
+++ b/graphics/icat/pkg-descr
@@ -0,0 +1,4 @@
+Displays an image in a 256-color enabled terminal with UTF-8 locale, such as
+gnome-terminal, konsole, uxterm or rxvt-unicode (urxvt).
+
+WWW: https://github.com/atextor/icat