aboutsummaryrefslogtreecommitdiff
path: root/graphics/iccxml
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-07-31 13:03:12 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-07-31 13:03:12 +0000
commit9577470cb817a809f6cb2195498639bb4cfac594 (patch)
tree8ca52805b746289571e93c3786010ede82dd21e3 /graphics/iccxml
parente8ec1931a6a2649287aa89920e2ca3bd2e861da9 (diff)
downloadports-9577470cb817a809f6cb2195498639bb4cfac594.tar.gz
ports-9577470cb817a809f6cb2195498639bb4cfac594.zip
. unbreak build with clang, error:
----- IccUtilXml.cpp:688:9: error: cannot initialize a variable of type 'char *' with an lvalue of type 'const char [2]' char *scanType = (Tsig == icSigFloatArrayType ? "f" : "n"); ^ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ----- . USE_GMAKE=yes -> USES=gmake.
Notes
Notes: svn path=/head/; revision=324044
Diffstat (limited to 'graphics/iccxml')
-rw-r--r--graphics/iccxml/Makefile4
-rw-r--r--graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp11
2 files changed, 12 insertions, 3 deletions
diff --git a/graphics/iccxml/Makefile b/graphics/iccxml/Makefile
index 7df3c4407b93..aa67afabb740 100644
--- a/graphics/iccxml/Makefile
+++ b/graphics/iccxml/Makefile
@@ -11,10 +11,8 @@ COMMENT= Tools for reading and writing the ICC profile contents as XML files
LIB_DEPENDS= SampleICC:${PORTSDIR}/graphics/sampleicc
-USES= pkgconfig
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GCC= any
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp b/graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp
new file mode 100644
index 000000000000..131bb62c29f2
--- /dev/null
+++ b/graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp
@@ -0,0 +1,11 @@
+--- IccLibXML/IccUtilXml.cpp.orig 2013-07-31 15:27:36.570207432 +0400
++++ IccLibXML/IccUtilXml.cpp 2013-07-31 15:28:45.056197105 +0400
+@@ -685,7 +685,7 @@ CIccXmlArrayType<T, Tsig>::~CIccXmlArray
+ template <class T, icTagTypeSignature Tsig>
+ bool CIccXmlArrayType<T, Tsig>::ParseArray(xmlNode *pNode)
+ {
+- char *scanType = (Tsig == icSigFloatArrayType ? "f" : "n");
++ char *scanType = (char *)(Tsig == icSigFloatArrayType ? "f" : "n");
+ icUInt32Number n = icXmlNodeCount(pNode, scanType);
+
+ if (n) {