aboutsummaryrefslogtreecommitdiff
path: root/graphics/iccxml
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2014-09-10 11:33:58 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2014-09-10 11:33:58 +0000
commitea2e29fe3453e85c0251bd5a298fbc5fdc34e1f6 (patch)
tree339cf1ce3159d3d5694cc8d4c7f0090a55e9635e /graphics/iccxml
parent5fb586df10cbbd0eba8afd224579652cde8c2610 (diff)
downloadports-ea2e29fe3453e85c0251bd5a298fbc5fdc34e1f6.tar.gz
ports-ea2e29fe3453e85c0251bd5a298fbc5fdc34e1f6.zip
graphics/iccxml: Update to v0.9.8 and unbreak build with sampleicc 1.6.8.
Notes
Notes: svn path=/head/; revision=367810
Diffstat (limited to 'graphics/iccxml')
-rw-r--r--graphics/iccxml/Makefile5
-rw-r--r--graphics/iccxml/distinfo4
-rw-r--r--graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp11
3 files changed, 3 insertions, 17 deletions
diff --git a/graphics/iccxml/Makefile b/graphics/iccxml/Makefile
index 2b4fa61eed2d..423fa42d8011 100644
--- a/graphics/iccxml/Makefile
+++ b/graphics/iccxml/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= iccxml
-PORTVERSION= 0.9.6
-PORTREVISION= 2
+PORTVERSION= 0.9.8
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/IccXML-Src/${DISTNAME}
DISTNAME= IccXML-${PORTVERSION}
@@ -10,8 +9,6 @@ DISTNAME= IccXML-${PORTVERSION}
MAINTAINER= bsam@FreeBSD.org
COMMENT= Tools for reading and writing the ICC profile contents as XML files
-BROKEN= Fails to build with sampleicc 1.6.8
-
LIB_DEPENDS= libSampleICC.so:${PORTSDIR}/graphics/sampleicc
USES= gmake pathfix pkgconfig libtool
diff --git a/graphics/iccxml/distinfo b/graphics/iccxml/distinfo
index f1a4915e7aee..468a7bd08a22 100644
--- a/graphics/iccxml/distinfo
+++ b/graphics/iccxml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (IccXML-0.9.6.tar.gz) = 7b2c0a7ca1c3061d42309f1481ece24bbee657fd86b153b008aede2ea853a02e
-SIZE (IccXML-0.9.6.tar.gz) = 367102
+SHA256 (IccXML-0.9.8.tar.gz) = 939913d350c93f19e063e397ba2a5544975ea447c921222070dc3d9da14f20af
+SIZE (IccXML-0.9.8.tar.gz) = 394012
diff --git a/graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp b/graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp
deleted file mode 100644
index 131bb62c29f2..000000000000
--- a/graphics/iccxml/files/patch-IccLibXML_IccUtilXml.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- IccLibXML/IccUtilXml.cpp.orig 2013-07-31 15:27:36.570207432 +0400
-+++ IccLibXML/IccUtilXml.cpp 2013-07-31 15:28:45.056197105 +0400
-@@ -685,7 +685,7 @@ CIccXmlArrayType<T, Tsig>::~CIccXmlArray
- template <class T, icTagTypeSignature Tsig>
- bool CIccXmlArrayType<T, Tsig>::ParseArray(xmlNode *pNode)
- {
-- char *scanType = (Tsig == icSigFloatArrayType ? "f" : "n");
-+ char *scanType = (char *)(Tsig == icSigFloatArrayType ? "f" : "n");
- icUInt32Number n = icXmlNodeCount(pNode, scanType);
-
- if (n) {