aboutsummaryrefslogtreecommitdiff
path: root/graphics/icoutils/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-27 14:23:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-27 14:23:04 +0000
commit4754185b7dc692a7abacd5da5fb6a52ff914942a (patch)
tree1147d9a0cb5866c9e2320d9e2d15131fdb55de13 /graphics/icoutils/Makefile
parentb959fd503623447842f327473284c48e4a91bfd2 (diff)
downloadports-4754185b7dc692a7abacd5da5fb6a52ff914942a.tar.gz
ports-4754185b7dc692a7abacd5da5fb6a52ff914942a.zip
Notes
Diffstat (limited to 'graphics/icoutils/Makefile')
-rw-r--r--graphics/icoutils/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index e3a7a896ad8f..bda2922c1e13 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -13,20 +13,22 @@ LICENSE= GPLv3
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+OPTIONS_DEFINE= RESSCRIPTS
+RESSCRIPTS_DESC= PERL resource scripts
+
USE_BZIP2= yes
+USES= shebangfix
+SHEBANG_FILES= extresso/*.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls
MAKE_JOBS_SAFE= yes
-MAN1= icotool.1 wrestool.1
-PLIST_FILES= bin/icotool \
- bin/wrestool
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= RESSCRIPTS
-RESSCRIPTS_DESC= PERL resource scripts
+MAN1= icotool.1 wrestool.1
+PLIST_FILES= bin/icotool \
+ bin/wrestool
.include <bsd.port.options.mk>
@@ -36,10 +38,6 @@ USE_PERL5_RUN= yes
MAN1+= extresso.1 genresscript.1
PLIST_FILES+= bin/extresso \
bin/genresscript
-.else
-post-patch:
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in \
- ${FILESDIR}/extra-patch-configure.ac
.endif
.include <bsd.port.pre.mk>
@@ -48,4 +46,14 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in \
BROKEN= Does not link on sparc64
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s|extresso||' ${WRKSRC}/Makefile.in
+
+post-install:
+.if ${PORT_OPTIONS:MRESSCRIPTS}
+ @(cd ${WRKSRC}/extresso && ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+.endif
+
.include <bsd.port.post.mk>