aboutsummaryrefslogtreecommitdiff
path: root/graphics/iiview
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-06 08:01:57 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-06 08:01:57 +0000
commit216e28ffeccc3c914f2774ac793e687c0a121177 (patch)
tree0afad6e2027c924d2af6169551e1b17d3ace7152 /graphics/iiview
parentb291da379cd4d08c822cf19c8f6b3f0f4fc1bf0c (diff)
downloadports-216e28ffeccc3c914f2774ac793e687c0a121177.tar.gz
ports-216e28ffeccc3c914f2774ac793e687c0a121177.zip
Add patch that belongs to the previous commit.
Notes
Notes: svn path=/head/; revision=347169
Diffstat (limited to 'graphics/iiview')
-rw-r--r--graphics/iiview/files/patch-Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/iiview/files/patch-Makefile b/graphics/iiview/files/patch-Makefile
new file mode 100644
index 000000000000..28b64730aca5
--- /dev/null
+++ b/graphics/iiview/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- ./Makefile.orig 2012-01-19 16:01:21.000000000 +0100
++++ ./Makefile 2014-03-06 08:55:15.940151118 +0100
+@@ -52,13 +52,9 @@
+ LIBSFB = $(LIBS) -lncurses
+ LIBSFBONLY = $(IMGLIBS) -lm -lncurses
+
+-.if !defined(PREFIX)
+-PREFIX = /usr/local
+-.endif
++PREFIX ?= /usr/local
+
+-.if !defined(X11BASE)
+-X11BASE = /usr/X11R6
+-.endif
++X11BASE = ${LOCALBASE}
+
+ # Please adjust this, if You get errors while compiling iiview
+ INCPATH = -I$(PREFIX)/include -I$(X11BASE)/include \
+@@ -110,8 +106,9 @@
+ rm -f $(OBJS) $(OBJSFB) main.fbo *~
+
+ install:
+- install -m 755 $(EXECNAME) $(PREFIX)/bin
+- install -m 755 ./man/man1/iiview.1.gz $(PREFIX)/man/man1
++ strip $(EXECNAME)
++ install -m 755 $(EXECNAME) $(DESTDIR)$(PREFIX)/bin
++ install -m 755 ./man/man1/iiview.1.gz $(DESTDIR)$(MANPREFIX)/man/man1
+
+ main.o: common.h filelist.h modules.h xsupport.h fbsupport.h main.c
+ $(CC) $(DEFS) $(OPTS) $(WARN) -c -o main.o $(INCPATH) main.c