aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2019-03-25 13:00:23 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2019-03-25 13:00:23 +0000
commite3bc0d6c631649aed31cfd4799ed68377c17889a (patch)
treeac98206bc69b76b704c298ae4e6d2f7c48b5c4e5 /graphics/ilmbase
parent8c335c39c4a652471616a19edb738ef3abf94c76 (diff)
downloadports-e3bc0d6c631649aed31cfd4799ed68377c17889a.tar.gz
ports-e3bc0d6c631649aed31cfd4799ed68377c17889a.zip
Notes
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index f1219232398c..0d2ee32f001c 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -24,7 +24,10 @@ GNU_CONFIGURE= yes
# The configure script uses bash arrays
CONFIGURE_SHELL=${BASH_CMD}
CONFIGURE_ARGS= --disable-static
-MAKE_ARGS+= PTHREAD_LIBS="-pthread -lpthread"
+# libtool links C++ libraries with -nostdlib, which prevents -pthread from
+# having an effect (at least with clang). Make sure we also pass -lpthread so
+# we do link against libthr.so.
+CONFIGURE_ENV+= PTHREAD_LIBS="-pthread -lpthread"
TEST_TARGET= check
PORTDOCS= AUTHORS ChangeLog README.md
@@ -48,7 +51,6 @@ regression-test regression check:: test
post-configure:
${REINPLACE_CMD} -e 's/#define HAVE_UCONTEXT_H 1/#undef HAVE_UCONTEXT_H/' ${WRKSRC}/config/IlmBaseConfig.h
- ${REINPLACE_CMD} -e '/^libIlmThread_la_LIBADD/s/$$/ $$(PTHREAD_LIBS)/' ${WRKSRC}/IlmThread/Makefile
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libHalf.so.${VER}