aboutsummaryrefslogtreecommitdiff
path: root/graphics/imageindex
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-03 16:37:04 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-03 16:37:04 +0000
commit9110d8d5d340cf5fa7e7a59070603dd554e3959c (patch)
tree2d962d4e87e7ad1ce174227e3e82a177deebba2d /graphics/imageindex
parentda209745265b204a0d6734616ae37fcdc6077397 (diff)
Notes
Diffstat (limited to 'graphics/imageindex')
-rw-r--r--graphics/imageindex/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/graphics/imageindex/Makefile b/graphics/imageindex/Makefile
index 205bb096132e..bfec0b17433a 100644
--- a/graphics/imageindex/Makefile
+++ b/graphics/imageindex/Makefile
@@ -9,31 +9,27 @@ MASTER_SITES= http://www.edwinh.org/imageindex/release/ \
http://www.reynoldsnet.org/imageindex/release/
MAINTAINER= johnjen@reynoldsnet.org
-COMMENT= A digital photo gallery tool
+COMMENT= Digital photo gallery tool
-RUN_DEPENDS= \
- ${LOCALBASE}/bin/Magick-config:${PORTSDIR}/graphics/ImageMagick \
- ${LOCALBASE}/bin/wrjpgcom:${PORTSDIR}/graphics/jpeg \
- ${LOCALBASE}/bin/mplayer:${PORTSDIR}/multimedia/mplayer \
- p5-Image-Info>=0:${PORTSDIR}/graphics/p5-Image-Info
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ mplayer:${PORTSDIR}/multimedia/mplayer \
+ p5-Image-Info>=0:${PORTSDIR}/graphics/p5-Image-Info
USES= perl5
USE_PERL5= run
-MAKE_ARGS+= PERLPATH=${PERL}
+MAKE_ARGS+= PERLPATH=${PERL} PREFIX=${STAGEDIR}${PREFIX}
-PLIST_FILES= bin/imageindex bin/autocaption
+PLIST_FILES= bin/imageindex bin/autocaption \
+ man/man1/imageindex.1.gz
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
-MAN1= imageindex.1
-
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e 's|share/man|man| ;' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/Makefile
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>