aboutsummaryrefslogtreecommitdiff
path: root/graphics/imc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 21:34:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-25 21:34:35 +0000
commit7954f5831525a642c915843bf09b31c1ac19e1f0 (patch)
tree643e6c13cb4a7342e166f29cfad3e11f41d823c5 /graphics/imc
parent14d87c7319de7e9640260371a73ae4858f786e35 (diff)
downloadports-7954f5831525a642c915843bf09b31c1ac19e1f0.tar.gz
ports-7954f5831525a642c915843bf09b31c1ac19e1f0.zip
Support stage
Add DOCS and EXAMPLES options USE_GMAKE -> USES=gmake
Notes
Notes: svn path=/head/; revision=341113
Diffstat (limited to 'graphics/imc')
-rw-r--r--graphics/imc/Makefile28
1 files changed, 11 insertions, 17 deletions
diff --git a/graphics/imc/Makefile b/graphics/imc/Makefile
index a5600080d6b9..e60b226535d7 100644
--- a/graphics/imc/Makefile
+++ b/graphics/imc/Makefile
@@ -10,18 +10,19 @@ MASTER_SITES= http://www.peterverthez.net/projects/imc/
MAINTAINER= ports@FreeBSD.org
COMMENT= Image Compiler
+OPTIONS_DEFINE= DOCS EXAMPLES
+
LICENSE= GPLv2
BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= gmake perl5
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-PLIST_FILES= bin/${PORTNAME}
-MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
PORTDOCS= *
@@ -34,19 +35,12 @@ DOC_FILES2= *.html *.ref *.txt
PORTEXAMPLES= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
- ${MKDIR} ${DOCSDIR2}
- ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>