aboutsummaryrefslogtreecommitdiff
path: root/graphics/imc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-06 23:23:47 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-06 23:23:47 +0000
commit8db6e4ba465d5e8d75cba3bd34c9975c5963400d (patch)
tree5053c1a93b538a7f121716878d705eba130be851 /graphics/imc
parent06cbabc4ce9d62a663fc699591711b8c43627891 (diff)
downloadports-8db6e4ba465d5e8d75cba3bd34c9975c5963400d.tar.gz
ports-8db6e4ba465d5e8d75cba3bd34c9975c5963400d.zip
- Clarify LICENSE
- Add LICENSE_FILE - Add NO_ARCH - Switch to options helpers - Simplify docs installation
Notes
Notes: svn path=/head/; revision=408329
Diffstat (limited to 'graphics/imc')
-rw-r--r--graphics/imc/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/graphics/imc/Makefile b/graphics/imc/Makefile
index 4a1be43fb751..635d9b43e4ce 100644
--- a/graphics/imc/Makefile
+++ b/graphics/imc/Makefile
@@ -10,7 +10,8 @@ MASTER_SITES= http://www.peterverthez.net/projects/imc/
MAINTAINER= ports@FreeBSD.org
COMMENT= Image Compiler
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
p5-CGI>=0:${PORTSDIR}/www/p5-CGI
@@ -18,28 +19,23 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake perl5
GNU_CONFIGURE= yes
+NO_ARCH= yes
-OPTIONS_DEFINE= DOCS EXAMPLES
-
+PORTDOCS= *
+PORTEXAMPLES= *
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
-PORTDOCS= *
-
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= AUTHORS ChangeLog NEWS README THANKS Todo
+OPTIONS_DEFINE= DOCS EXAMPLES
-DOCSRCDIR2= ${WRKSRC}/doc
-DOCSDIR2= ${DOCSDIR}/doc
-DOC_FILES2= *.html *.ref *.txt
-PORTEXAMPLES= *
-
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
- ${MKDIR} ${STAGEDIR}${DOCSDIR2}
- ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+ cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog NEWS README THANKS Todo \
+ ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html *.ref *.txt ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})