aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-29 12:22:41 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-29 12:22:41 +0000
commit8be884c8250007933e12926de643950b5d3e9b61 (patch)
tree73156d7aac68e7acd5de7f447dd1fe677c7c44f0 /graphics/imlib2
parentf94d7ff50cdc008cde77be9ecbe6ff3e8d5a4643 (diff)
downloadports-8be884c8250007933e12926de643950b5d3e9b61.tar.gz
ports-8be884c8250007933e12926de643950b5d3e9b61.zip
- backout last fix
Acording to submitter the last version does not work. Submitted by: Dominic Fandrey
Notes
Notes: svn path=/head/; revision=251718
Diffstat (limited to 'graphics/imlib2')
-rw-r--r--graphics/imlib2/Makefile2
-rw-r--r--graphics/imlib2/files/patch-loader_png.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index d482b1c1dcaa..24055314dc34 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib2
PORTVERSION= 1.4.1.000
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
diff --git a/graphics/imlib2/files/patch-loader_png.c b/graphics/imlib2/files/patch-loader_png.c
index 124961969439..5444c6260bad 100644
--- a/graphics/imlib2/files/patch-loader_png.c
+++ b/graphics/imlib2/files/patch-loader_png.c
@@ -5,7 +5,7 @@
/* if we haven't read the header before, set the header data */
fread(buf, 1, PNG_BYTES_TO_CHECK, f);
- if (!png_check_sig(buf, PNG_BYTES_TO_CHECK))
-+ if (png_check_sig(buf, 0, PNG_BYTES_TO_CHECK))
++ if (png_check_sig(buf, 0, PNG_BYTES_TO_CHECK) != 0)
{
fclose(f);
return 0;