aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:58:45 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:58:45 +0000
commit09fa4f371396ff884f3845939561bfc786faf491 (patch)
treec96433e62a8936a335927334ac78ce394f59c079 /graphics/inkscape
parent7887c684adab042fed1bfcba2e91589ecd17c4a8 (diff)
downloadports-09fa4f371396ff884f3845939561bfc786faf491.tar.gz
ports-09fa4f371396ff884f3845939561bfc786faf491.zip
Notes
Diffstat (limited to 'graphics/inkscape')
-rw-r--r--graphics/inkscape/Makefile44
-rw-r--r--graphics/inkscape/distinfo4
-rw-r--r--graphics/inkscape/files/patch-Makefile.in25
-rw-r--r--graphics/inkscape/files/patch-src_extension_internal_pdfinput_svg-builder.cpp11
-rw-r--r--graphics/inkscape/files/patch-src_helper_png-write.cpp11
-rw-r--r--graphics/inkscape/files/patch-src_sp-image.cpp11
-rw-r--r--graphics/inkscape/pkg-plist3
7 files changed, 49 insertions, 60 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 308cbd4d89e9..0ec317b57693 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -1,33 +1,29 @@
-# New ports collection makefile for: inkscape
-# Date created: 17 Nov 2003
-# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
-#
+# Created by: Alexander Nedotsukov <bland@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= inkscape
-PORTVERSION= 0.48.2
-PORTREVISION= 3
+PORTVERSION= 0.48.4
CATEGORIES= graphics gnome
MASTER_SITES= SF
MASTER_SITE_SUBDIR=${PORTNAME:L}/${PORTNAME:L}/${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A program seeks to become a full featured open source SVG editor
+COMMENT= Full featured open source SVG editor
BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
- gc.1:${PORTSDIR}/devel/boehm-gc \
- gsl.16:${PORTSDIR}/math/gsl \
- gtkspell.0:${PORTSDIR}/textproc/gtkspell \
- lcms.1:${PORTSDIR}/graphics/lcms \
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
+ gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ gc:${PORTSDIR}/devel/boehm-gc \
+ gsl:${PORTSDIR}/math/gsl \
+ gtkspell:${PORTSDIR}/textproc/gtkspell \
+ lcms:${PORTSDIR}/graphics/lcms \
wpg-0.2:${PORTSDIR}/graphics/libwpg \
png15:${PORTSDIR}/graphics/png \
Magick++:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS= p5-XML-XQL>=0:${PORTSDIR}/textproc/p5-XML-XQL
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
@@ -39,23 +35,25 @@ INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-MAN1= inkscape.1
-MAN1_EN= inkview.1
-MANLANG= "" fr
+MAN1= inkscape.1 inkview.1
+NO_MANCOMPRESS= yes
-OPTIONS= POPPLER "Enable libpoppler-cairo for rendering PDF preview" on
+OPTIONS_DEFINE= GNOMEVFS POPPLER
+OPTIONS_DEFAULT=POPPLER
+POPPLER_DESC= PDF preview rendering
+GNOMEVFS_DESC= Use gnomevfs for loading files
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${HAVE_GNOME:Mgnomevfs2} != ""
+.if ${PORT_OPTIONS:MGNOMEVFS}
USE_GNOME+= gnomevfs2
CONFIGURE_ARGS+= --with-gnome-vfs
.else
CONFIGURE_ARGS+= --without-gnome-vfs
.endif
-.if defined(WITH_POPPLER)
-LIB_DEPENDS+= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib
+.if ${PORT_OPTIONS:MPOPPLER}
+LIB_DEPENDS+= poppler-glib:${PORTSDIR}/graphics/poppler-glib
CONFIGURE_ARGS+= --enable-poppler-cairo
.else
CONFIGURE_ARGS+= --enable-poppler-cairo=no
@@ -77,4 +75,4 @@ post-patch:
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/inkscape/distinfo b/graphics/inkscape/distinfo
index c9ae4d83eda7..0989450431aa 100644
--- a/graphics/inkscape/distinfo
+++ b/graphics/inkscape/distinfo
@@ -1,2 +1,2 @@
-SHA256 (inkscape-0.48.2.tar.bz2) = 223a42ba6e3644bb2956c485ca0c210edc14e90fa882cdc57c1bb9f35b8f6783
-SIZE (inkscape-0.48.2.tar.bz2) = 19583331
+SHA256 (inkscape-0.48.4.tar.bz2) = 8741ad8cbb5aa5cee4f234ebc45479cff2479b16d903870693174bdede8a519d
+SIZE (inkscape-0.48.4.tar.bz2) = 19712522
diff --git a/graphics/inkscape/files/patch-Makefile.in b/graphics/inkscape/files/patch-Makefile.in
new file mode 100644
index 000000000000..96072f3341a3
--- /dev/null
+++ b/graphics/inkscape/files/patch-Makefile.in
@@ -0,0 +1,25 @@
+--- Makefile.in.orig 2013-03-07 08:40:14.000000000 +0000
++++ Makefile.in 2013-03-07 08:59:34.000000000 +0000
+@@ -421,11 +421,6 @@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+ man_MANS = \
+ inkscape.1 \
+- inkscape.el.1 \
+- inkscape.fr.1 \
+- inkscape.ja.1 \
+- inkscape.sk.1 \
+- inkscape.zh_TW.1 \
+ inkview.1
+
+ EXTRA_DIST = \
+@@ -1351,9 +1346,7 @@
+
+ info-am:
+
+-install-data-am: install-GraphicsDATA install-man install-manelDATA \
+- install-manfrDATA install-manjaDATA install-manskDATA \
+- install-manzhtwDATA
++install-data-am: install-GraphicsDATA install-man
+
+ install-dvi: install-dvi-recursive
+
diff --git a/graphics/inkscape/files/patch-src_extension_internal_pdfinput_svg-builder.cpp b/graphics/inkscape/files/patch-src_extension_internal_pdfinput_svg-builder.cpp
deleted file mode 100644
index e9e49d9930b6..000000000000
--- a/graphics/inkscape/files/patch-src_extension_internal_pdfinput_svg-builder.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/extension/internal/pdfinput/svg-builder.cpp.orig 2012-05-04 10:06:12.000000000 +0200
-+++ src/extension/internal/pdfinput/svg-builder.cpp 2012-05-04 12:24:12.000000000 +0200
-@@ -1443,7 +1443,7 @@
- return NULL;
- }
- // Set error handler
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- png_destroy_write_struct(&png_ptr, &info_ptr);
- return NULL;
- }
diff --git a/graphics/inkscape/files/patch-src_helper_png-write.cpp b/graphics/inkscape/files/patch-src_helper_png-write.cpp
deleted file mode 100644
index 078b4252c930..000000000000
--- a/graphics/inkscape/files/patch-src_helper_png-write.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/helper/png-write.cpp.orig 2012-05-04 10:06:13.000000000 +0200
-+++ src/helper/png-write.cpp 2012-05-04 12:02:19.000000000 +0200
-@@ -165,7 +165,7 @@
- /* Set error handling. REQUIRED if you aren't supplying your own
- * error hadnling functions in the png_create_write_struct() call.
- */
-- if (setjmp(png_ptr->jmpbuf)) {
-+ if (setjmp(png_jmpbuf(png_ptr))) {
- /* If we get here, we had a problem reading the file */
- fclose(fp);
- png_destroy_write_struct(&png_ptr, &info_ptr);
diff --git a/graphics/inkscape/files/patch-src_sp-image.cpp b/graphics/inkscape/files/patch-src_sp-image.cpp
deleted file mode 100644
index 6b1fed560818..000000000000
--- a/graphics/inkscape/files/patch-src_sp-image.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/sp-image.cpp.orig 2011-07-08 20:25:09.468790000 +0200
-+++ src/sp-image.cpp 2012-05-05 08:06:14.000000000 +0200
-@@ -388,7 +388,7 @@
- {
- char* name = 0;
- int compression_type = 0;
-- char* profile = 0;
-+ png_byte * profile = 0;
- png_uint_32 proflen = 0;
- if ( png_get_iCCP(pngPtr, infoPtr, &name, &compression_type, &profile, &proflen) ) {
- // g_message("Found an iCCP chunk named [%s] with %d bytes and comp %d", name, proflen, compression_type);
diff --git a/graphics/inkscape/pkg-plist b/graphics/inkscape/pkg-plist
index f198c5c525ca..08d062a2b033 100644
--- a/graphics/inkscape/pkg-plist
+++ b/graphics/inkscape/pkg-plist
@@ -415,6 +415,7 @@ share/icons/hicolor/48x48/apps/inkscape.png
%%DATADIR%%/extensions/uniconv-ext.py
%%DATADIR%%/extensions/uniconv_output.py
%%DATADIR%%/extensions/voronoi.py
+%%DATADIR%%/extensions/voronoi2svg.py
%%DATADIR%%/extensions/web-set-att.inx
%%DATADIR%%/extensions/web-set-att.py
%%DATADIR%%/extensions/web-transmit-att.inx
@@ -852,8 +853,6 @@ share/locale/zh_TW/LC_MESSAGES/inkscape.mo
@dirrm %%DATADIR%%/clipart
@dirrm %%DATADIR%%
@dirrmtry share/applications
-@dirrmtry man/fr/man1
-@dirrmtry man/fr
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/te_IN/LC_MESSAGES