aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-22 17:59:22 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-22 17:59:22 +0000
commit90a4ed701a4a68d4ed2c54b96f8f5371dbfd9ffb (patch)
treeb78dc987b5630ee8fd0fcabe9d02b299721bed32 /graphics/inkscape
parentb3f15f1bc762df52e33fc20b9e42fc97b3b36a67 (diff)
downloadports-90a4ed701a4a68d4ed2c54b96f8f5371dbfd9ffb.tar.gz
ports-90a4ed701a4a68d4ed2c54b96f8f5371dbfd9ffb.zip
graphics/poppler: update to 0.84.0
Release 0.84.0: core: * Fix crash when converting from Unicode to ASCII-7 * Splash::scaleImageYdXu: Protect against crash if srcWidth is too big * JBIG2Stream: fix potential crash in malformed documents * JBIG2Stream: fix leak in reset() if called several times * Internal code improvements utils: * pdfimages: Add error message if first page is larger then number of pages. * pdfinfo: Improved paper size recognition * pdfsig: Fix exit code when dumping signatures * pdftocairo: Error out when even/odd selects 0 pages * pdftohtml: Fix memory leak * pdftoppm: Add an option to scale before rotate * pdftoppm: Add -hide-annotations option * pdftoppm: Error out when even/odd selects 0 pages * pdftops: Improve -optimizecolorspace qt5: * Code cleanups glib: * Fix compiler warnings Release 0.83.0 core: * Improve when a file is recognized as Linearized * Improve const-ness of the code * Make code a bit more readable/maintanable * Fix uninitialized memory uses in broken files utils: * pdffonts: Make code a bit more readable/maintanable * pdftohtml: Make code a bit more readable/maintanable qt5: * Remove a bunch of unused internal functions * trUtf8 -> tr (less warnings) build system: * make-glib-api-docs: switch to python3 PR: 243433 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=523824
Diffstat (limited to 'graphics/inkscape')
-rw-r--r--graphics/inkscape/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 23d86bd88d12..6bea2cc4dd31 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inkscape
PORTVERSION= 0.92.4
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= graphics gnome
MASTER_SITES= https://media.inkscape.org/dl/resources/file/
@@ -94,5 +94,11 @@ post-patch:
# Fix with poppler 0.73
@${REINPLACE_CMD} -E '/#include "goo\/gtypes.h"/d' \
${WRKSRC}/src/extension/internal/pdfinput/pdf-parser.h
+ # Fix build with poppler 0.83
+ ${REINPLACE_CMD} -e 's|(GfxPath|(const GfxPath|g' \
+ -e 's|GfxSubpath|const GfxSubpath|g' \
+ -e 's|new GlobalParams()|std::unique_ptr<GlobalParams>(new GlobalParams())|g' \
+ -e 's|new GlobalParams(poppler_datadir)|std::unique_ptr<GlobalParams>(new GlobalParams(poppler_datadir))|g' \
+ ${WRKSRC}/src/extension/internal/pdfinput/*.cpp
.include <bsd.port.mk>