aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-11-01 10:25:41 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-11-01 10:25:41 +0000
commitc52c540cb4a6f1277af95744e61effc54656e99a (patch)
tree5a1f14978e26c96a28efb6f34ac6df3d47eec20f /graphics/ipe/Makefile
parent75d0632ce4079947fd1ae813c8a93f8a3ab73909 (diff)
downloadports-c52c540cb4a6f1277af95744e61effc54656e99a.tar.gz
ports-c52c540cb4a6f1277af95744e61effc54656e99a.zip
Notes
Diffstat (limited to 'graphics/ipe/Makefile')
-rw-r--r--graphics/ipe/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 3a1973ecdcd6..a8710973b2f6 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ipe
-PORTVERSION= 7.2.19
+PORTVERSION= 7.2.21
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= https://dl.bintray.com/otfried/generic/ipe/${PORTVERSION:R}/
@@ -18,12 +18,13 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libgsl.so:math/gsl \
libpng.so:graphics/png
-USES= compiler:c++11-lib gmake gnome jpeg lua:52 pkgconfig qt:5
+USES= compiler:c++11-lib gmake gnome jpeg lua:52 pkgconfig shebangfix qt:5
USE_GNOME= cairo
USE_QT= buildtools_build core gui qmake_build widgets
USE_TEX= pdftex
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+SHEBANG_FILES= ${WRKSRC}/ipecurl/ipecurl.sh
MAKE_ENV= DL_LIBS="" \
INSTALL_DIR="${MKDIR}" \
@@ -50,9 +51,6 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e \
- 's|^INSTALL_|#INSTALL_| ; \
- /-O2/s|^|#|' ${WRKSRC}/common.mak
- @${REINPLACE_CMD} -e \
's|\([[:blank:]]\)=|\1?=|' ${WRKSRC}/config.mak
post-install: