aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-13 17:14:53 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-13 17:14:53 +0000
commit42cea4feca97175ce7fe8e01cef19ba73b69c476 (patch)
treedb7d60e9baca3e8f203bee4b35e80db32ed1fe56 /graphics/ipe
parent31c9fcf7327a4faf7e0c2a77beaef9643cdd87a4 (diff)
downloadports-42cea4feca97175ce7fe8e01cef19ba73b69c476.tar.gz
ports-42cea4feca97175ce7fe8e01cef19ba73b69c476.zip
- Fix build after iconv change [1]
- Fix build with clang/libc++ ([2] for graphics/ipe) While here for databases/spatialite: - Trim Makefile headers - Remove check for unsupported FreeBSD versions Submitted by: marino [1] Reported by: swills, antoine [1] Submitted by: bsam [2] Approved by: portmgr (bapt, implicit)
Notes
Notes: svn path=/head/; revision=327168
Diffstat (limited to 'graphics/ipe')
-rw-r--r--graphics/ipe/Makefile3
-rw-r--r--graphics/ipe/files/patch-include__ipebase.h11
2 files changed, 12 insertions, 2 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 30b2e4e182a0..0366fb552257 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -20,10 +20,9 @@ OPTIONS_DEFINE= DOCS
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-USES= pkgconfig
+USES= gmake iconv pkgconfig
USE_QT4= gui moc_build qmake_build rcc_build uic_build
USE_TEX= latex
-USE_GMAKE= yes
MAKE_ENV= DLL_CFLAGS="-fPIC" \
ICONV_CFLAGS="-I${LOCALBASE}/include" \
ICONV_LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}" \
diff --git a/graphics/ipe/files/patch-include__ipebase.h b/graphics/ipe/files/patch-include__ipebase.h
new file mode 100644
index 000000000000..dcd1d8be7291
--- /dev/null
+++ b/graphics/ipe/files/patch-include__ipebase.h
@@ -0,0 +1,11 @@
+--- include/ipebase.h.orig 2013-09-13 12:51:35.422094300 +0400
++++ include/ipebase.h 2013-09-13 12:52:10.808993351 +0400
+@@ -38,6 +38,8 @@
+ #include <map>
+ #include <list>
+ #include <algorithm>
++#include <cstdlib>
++#include <sys/types.h>
+
+ // --------------------------------------------------------------------
+