aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-06-11 18:47:33 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-06-11 18:47:33 +0000
commit488b6cff8b6237d7ae78079daaceb341277d8884 (patch)
tree05f228885c40257e83a8edb9ea0f8c07944fdd60 /graphics/ipe
parentb60df2ac281f21b9a96b17d0654a8456c739f1d2 (diff)
downloadports-488b6cff8b6237d7ae78079daaceb341277d8884.tar.gz
ports-488b6cff8b6237d7ae78079daaceb341277d8884.zip
graphics/ipe: fix build with GCC-based architectures
PR: 238066 Submitted by: pkubaj
Notes
Notes: svn path=/head/; revision=503974
Diffstat (limited to 'graphics/ipe')
-rw-r--r--graphics/ipe/Makefile1
-rw-r--r--graphics/ipe/files/patch-ipelib_ipeplatform.cpp5
2 files changed, 4 insertions, 2 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 15e3f46f0d02..d953539acf04 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ipe
PORTVERSION= 7.2.12
+PORTREVISION= 1
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= https://dl.bintray.com/otfried/generic/ipe/${PORTVERSION:R}/
diff --git a/graphics/ipe/files/patch-ipelib_ipeplatform.cpp b/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
index 5bf8860729cb..1982f4f54ceb 100644
--- a/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
+++ b/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
@@ -1,11 +1,12 @@
---- ipelib/ipeplatform.cpp.orig 2019-03-09 12:21:05 UTC
+--- ipelib/ipeplatform.cpp.orig 2019-05-02 09:29:29 UTC
+++ ipelib/ipeplatform.cpp
-@@ -48,7 +48,10 @@
+@@ -48,7 +48,11 @@
#include <sys/param.h>
#include <sys/errno.h>
#endif
-
+#if defined(__FreeBSD__) || defined(__DragonFly__)
++#include <limits.h>
+#include <xlocale.h>
+#include <sys/errno.h>
+#endif