aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-02-11 16:57:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-02-11 16:57:37 +0000
commita96165d3035a019ea2da4422eb3a313ca7663acc (patch)
treecca2e761b60287f096b28187f675be8dc2fa46c3 /graphics/ipe
parent3676ffc10c6bced1052919a6c5e6d967ea96524b (diff)
downloadports-a96165d3035a019ea2da4422eb3a313ca7663acc.tar.gz
ports-a96165d3035a019ea2da4422eb3a313ca7663acc.zip
graphics/ipe: Update version 7.2.21=>7.2.23
Notes
Notes: svn path=/head/; revision=564965
Diffstat (limited to 'graphics/ipe')
-rw-r--r--graphics/ipe/Makefile9
-rw-r--r--graphics/ipe/distinfo6
-rw-r--r--graphics/ipe/files/patch-ipelib_ipeplatform.cpp11
3 files changed, 15 insertions, 11 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index a8710973b2f6..92a64c85987d 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ipe
-PORTVERSION= 7.2.21
+PORTVERSION= 7.2.23
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= https://dl.bintray.com/otfried/generic/ipe/${PORTVERSION:R}/
@@ -16,7 +16,8 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
LIB_DEPENDS= libcurl.so:ftp/curl \
libfreetype.so:print/freetype2 \
libgsl.so:math/gsl \
- libpng.so:graphics/png
+ libpng.so:graphics/png \
+ libspiro.so:graphics/libspiro
USES= compiler:c++11-lib gmake gnome jpeg lua:52 pkgconfig shebangfix qt:5
USE_GNOME= cairo
@@ -56,5 +57,9 @@ post-patch:
post-install:
@${LN} -sf ${DATADIR}/${PORTVERSION}/ipe.png \
${STAGEDIR}${PREFIX}/share/pixmaps
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libipe*
+.for filename in ipe6upgrade iperender ipeextract ipescript ipetoipe ipepresenter ipe
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${filename}
+.endfor
.include <bsd.port.mk>
diff --git a/graphics/ipe/distinfo b/graphics/ipe/distinfo
index 667848f374dc..1c2a939c4753 100644
--- a/graphics/ipe/distinfo
+++ b/graphics/ipe/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604181190
-SHA256 (ipe-7.2.21-src.tar.gz) = 42936f822c541bbe108617ac018a34a520cae2f870b60402af0cda61868934c3
-SIZE (ipe-7.2.21-src.tar.gz) = 2005014
+TIMESTAMP = 1611709798
+SHA256 (ipe-7.2.23-src.tar.gz) = a19ba29822e63fc7c12c3b85ca5bb58f9ee72fdf566e148af79206b5dc1f757b
+SIZE (ipe-7.2.23-src.tar.gz) = 1030938
diff --git a/graphics/ipe/files/patch-ipelib_ipeplatform.cpp b/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
index 1982f4f54ceb..89d6d8362a52 100644
--- a/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
+++ b/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
@@ -1,15 +1,14 @@
---- ipelib/ipeplatform.cpp.orig 2019-05-02 09:29:29 UTC
+--- ipelib/ipeplatform.cpp.orig 2020-12-24 12:20:13 UTC
+++ ipelib/ipeplatform.cpp
-@@ -48,7 +48,11 @@
+@@ -49,6 +49,11 @@
#include <sys/param.h>
#include <sys/errno.h>
#endif
--
+#if defined(__FreeBSD__) || defined(__DragonFly__)
+#include <limits.h>
+#include <xlocale.h>
+#include <sys/errno.h>
+#endif
- #include <cstdlib>
- #include <sys/types.h>
- #include <sys/stat.h>
+
+ #ifdef IPE_GSL
+ #include <gsl/gsl_errno.h>