aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-01-12 11:49:33 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-01-12 11:49:33 +0000
commitab781b2cf963fb397c4ef214fa9ccb36f73a7702 (patch)
treeb7ab432b173b4096adfd8ae05a38068b1b3e8846 /graphics/ipe
parent7d8446263364f18f0457cd98b1e3ada77b78e66f (diff)
downloadports-ab781b2cf963fb397c4ef214fa9ccb36f73a7702.tar.gz
ports-ab781b2cf963fb397c4ef214fa9ccb36f73a7702.zip
graphics/ipe: Update version 7.2.7=>7.2.8
Notes
Notes: svn path=/head/; revision=490050
Diffstat (limited to 'graphics/ipe')
-rw-r--r--graphics/ipe/Makefile10
-rw-r--r--graphics/ipe/distinfo6
-rw-r--r--graphics/ipe/files/patch-ipelib_ipeplatform.cpp13
3 files changed, 21 insertions, 8 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 4bf2aadf633f..d26500a2868f 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ipe
-PORTVERSION= 7.2.7
-PORTREVISION= 4
+PORTVERSION= 7.2.8
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= https://dl.bintray.com/otfried/generic/ipe/${PORTVERSION:R}/
@@ -17,12 +16,13 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-
-USES= compiler:c++11-lib gmake jpeg lua:52 pkgconfig qt:5
+USES= compiler:c++11-lib gmake gnome jpeg lua:52 pkgconfig qt:5
USE_GNOME= cairo
USE_QT= buildtools_build core gui qmake_build widgets
USE_TEX= pdftex
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
MAKE_ENV= DL_LIBS="" \
INSTALL_DIR="${MKDIR}" \
INSTALL_FILES="${INSTALL_DATA}" \
diff --git a/graphics/ipe/distinfo b/graphics/ipe/distinfo
index 511660610e16..a03367cedf1b 100644
--- a/graphics/ipe/distinfo
+++ b/graphics/ipe/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1488110032
-SHA256 (ipe-7.2.7-src.tar.gz) = d66d3f2619e3e6ff617f42c2e3695c3db6e2a64adcc3d7613214e5fd14c49f22
-SIZE (ipe-7.2.7-src.tar.gz) = 1561350
+TIMESTAMP = 1547285171
+SHA256 (ipe-7.2.8-src.tar.gz) = fe0927db42c97133d8368f59114fa1e904692be5330c14244bbbb997fb1b33d7
+SIZE (ipe-7.2.8-src.tar.gz) = 1847318
diff --git a/graphics/ipe/files/patch-ipelib_ipeplatform.cpp b/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
new file mode 100644
index 000000000000..ecaaa941f1c7
--- /dev/null
+++ b/graphics/ipe/files/patch-ipelib_ipeplatform.cpp
@@ -0,0 +1,13 @@
+--- ipelib/ipeplatform.cpp.orig 2019-01-12 09:37:35 UTC
++++ ipelib/ipeplatform.cpp
+@@ -44,7 +44,9 @@
+ #include <mach-o/dyld.h>
+ #include <xlocale.h>
+ #endif
+-
++#if defined(__FreeBSD__) || defined(__DragonFly__)
++#include <xlocale.h>
++#endif
+ #include <cstdlib>
+ #include <sys/types.h>
+ #include <sys/stat.h>