aboutsummaryrefslogtreecommitdiff
path: root/graphics/jasper
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-15 04:17:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-15 04:17:04 +0000
commit45db254fb4ed9e5fe83ed9767cb0aefccac61410 (patch)
tree78851a4a08068d9a8c470fbc2f3ac8b85c1074cb /graphics/jasper
parentff07ef6570d4c624e619a0eb1ac0a2d9b24801e5 (diff)
downloadports-45db254fb4ed9e5fe83ed9767cb0aefccac61410.tar.gz
ports-45db254fb4ed9e5fe83ed9767cb0aefccac61410.zip
Clean up Makefile
- Use USES=localbase - Sort USES - Convert to options variable helper - Update WWW - Add GitHub repository to WWW - Take maintainership
Notes
Notes: svn path=/head/; revision=431514
Diffstat (limited to 'graphics/jasper')
-rw-r--r--graphics/jasper/Makefile33
-rw-r--r--graphics/jasper/pkg-descr5
2 files changed, 12 insertions, 26 deletions
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
index d3b903f77839..70f55b0b336b 100644
--- a/graphics/jasper/Makefile
+++ b/graphics/jasper/Makefile
@@ -8,40 +8,27 @@ CATEGORIES= graphics
MASTER_SITES= http://www.ece.uvic.ca/~mdadams/jasper/software/ \
ftp://ftp.imagemagick.org/pub/ImageMagick/delegates/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Implementation of the codec specified in the JPEG-2000 standard
LICENSE= MIT
-USES= zip libtool:keepla jpeg
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --enable-shared --enable-static
-USE_LDCONFIG= yes
-
OPTIONS_DEFINE= OPENGL UUID DOCS
OPTIONS_DEFAULT=UUID
+OPTIONS_SUB= yes
UUID_DESC= UUID support (required by GDAL)
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENGL}
-USE_XORG= x11 xmu xi xext
-USE_GL= glut
-CONFIGURE_ARGS+=--enable-opengl
-PLIST_SUB+= OPENGL=""
-.else
-CONFIGURE_ARGS+=--disable-opengl
-PLIST_SUB+= OPENGL="@comment "
-.endif
+CONFIGURE_ARGS= --enable-shared --enable-static
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= jpeg libtool:keepla localbase zip
-.if ${PORT_OPTIONS:MUUID}
-EXTRA_PATCHES+= ${FILESDIR}/uuid.patch
-.endif
+OPENGL_CONFIGURE_ENABLE=opengl
+OPENGL_USE= GL=glut XORG=x11,xext,xi,xmu
+UUID_EXTRA_PATCHES= ${PATCHDIR}/uuid.patch
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/graphics/jasper/pkg-descr b/graphics/jasper/pkg-descr
index f70e0effe539..65e66fd07623 100644
--- a/graphics/jasper/pkg-descr
+++ b/graphics/jasper/pkg-descr
@@ -2,6 +2,5 @@ JasPer is a software-based implementation of the codec specified in the
emerging JPEG-2000 Part-1 standard (i.e., ISO/IEC 15444-1). The JasPer software
is written in the C programming language.
-LICENSE: MIT
-
-WWW: http://www.ece.uvic.ca/~mdadams/jasper/
+WWW: http://www.ece.uvic.ca/~frodo/jasper/
+WWW: https://github.com/mdadams/jasper