aboutsummaryrefslogtreecommitdiff
path: root/graphics/jasper
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2019-12-27 18:18:29 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2019-12-27 18:18:29 +0000
commit95ac0093f940ef7f41fbaa6755d81563bce9c28e (patch)
tree9dcd45676735504f8ef88e2b722bd735f496854a /graphics/jasper
parent6cebbebaef3aa3e395e80291273fc1d8a479469c (diff)
downloadports-95ac0093f940ef7f41fbaa6755d81563bce9c28e.tar.gz
ports-95ac0093f940ef7f41fbaa6755d81563bce9c28e.zip
graphics/jasper: Add missing OPENGL dependencies, use CMAKE_BOOL
Reported by: danfe Approved by: bapt Differential Revision: https://reviews.freebsd.org/D22936
Notes
Notes: svn path=/head/; revision=521017
Diffstat (limited to 'graphics/jasper')
-rw-r--r--graphics/jasper/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
index ab226fcd6d1d..cb36d8430303 100644
--- a/graphics/jasper/Makefile
+++ b/graphics/jasper/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jasper
PORTVERSION= 2.0.16
+PORTREVISION= 1
DISTVERSIONPREFIX= version-
CATEGORIES= graphics
@@ -22,10 +23,9 @@ USE_GITHUB= yes
GH_ACCOUNT= mdadams
-OPENGL_CMAKE_OFF= -DJAS_ENABLE_OPENGL=false
-OPENGL_CMAKE_ON= -DJAS_ENABLE_OPENGL=true
+OPENGL_CMAKE_BOOL= JAS_ENABLE_OPENGL
OPENGL_USES= gl xorg
-OPENGL_USE= GL=glut XORG=x11,xext,xi,xmu
+OPENGL_USE= GL=gl,glu,glut XORG=x11,xext,xi,xmu
CMAKE_ARGS= -DJAS_ENABLE_JPEG=true \
-DJAS_ENABLE_AUTOMATIC_DEPENDENCIES=false \