aboutsummaryrefslogtreecommitdiff
path: root/graphics/jasper
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-12 14:58:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-12 14:58:19 +0000
commiteeeed9e282acd96937808dd7a204428dbe98af64 (patch)
treecd4f8ca36d14fe3cf6fd208d85f7f3fabf3120f6 /graphics/jasper
parent22772c937bc813fd10b7fa55f7bdee25fc244423 (diff)
downloadports-eeeed9e282acd96937808dd7a204428dbe98af64.tar.gz
ports-eeeed9e282acd96937808dd7a204428dbe98af64.zip
Update to 2.0.20
Changes: https://github.com/jasper-software/jasper/blob/master/NEWS PR: 248912 Exp-run by: antoine Security: 6842ac7e-d250-11ea-b9b7-08002728f74c MFH: 2020Q3
Notes
Notes: svn path=/head/; revision=548374
Diffstat (limited to 'graphics/jasper')
-rw-r--r--graphics/jasper/Makefile12
-rw-r--r--graphics/jasper/distinfo6
-rw-r--r--graphics/jasper/files/patch-CMakeLists.txt12
-rw-r--r--graphics/jasper/files/patch-build-cmake-modules-JasOpenGL.cmake11
-rw-r--r--graphics/jasper/pkg-plist1
5 files changed, 19 insertions, 23 deletions
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
index 42948cb8759d..b818e6f4088a 100644
--- a/graphics/jasper/Makefile
+++ b/graphics/jasper/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= jasper
-PORTVERSION= 2.0.16
-PORTREVISION= 1
+PORTVERSION= 2.0.20
DISTVERSIONPREFIX= version-
CATEGORIES= graphics
@@ -17,9 +16,8 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= cmake jpeg localbase
-CMAKE_ARGS= -DCMAKE_SKIP_RPATH=true \
- -DJAS_ENABLE_AUTOMATIC_DEPENDENCIES=false \
- -DJAS_ENABLE_JPEG=true
+CMAKE_OFF= JAS_ENABLE_AUTOMATIC_DEPENDENCIES
+CMAKE_ON= JAS_ENABLE_LIBJPEG
USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/JasPer
@@ -31,11 +29,9 @@ OPTIONS_DEFINE= OPENGL DOCS
OPTIONS_DEFAULT=OPENGL
OPTIONS_SUB= yes
+DOCS_CMAKE_BOOL= JAS_ENABLE_DOC
OPENGL_CMAKE_BOOL= JAS_ENABLE_OPENGL
OPENGL_USE= GL=gl,glu,glut XORG=x11,xext,xi,xmu
OPENGL_USES= gl xorg
-post-install-DOCS-off:
- rm -rf ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.mk>
diff --git a/graphics/jasper/distinfo b/graphics/jasper/distinfo
index 91d31d0876b9..64851c4f0cb5 100644
--- a/graphics/jasper/distinfo
+++ b/graphics/jasper/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1595416525
-SHA256 (jasper-software-jasper-version-2.0.16_GH0.tar.gz) = f1d8b90f231184d99968f361884e2054a1714fdbbd9944ba1ae4ebdcc9bbfdb1
-SIZE (jasper-software-jasper-version-2.0.16_GH0.tar.gz) = 1311944
+TIMESTAMP = 1599329835
+SHA256 (jasper-software-jasper-version-2.0.20_GH0.tar.gz) = d55843ce52afa9bfe90f30118329578501040f30d48a027459a68a962695e506
+SIZE (jasper-software-jasper-version-2.0.20_GH0.tar.gz) = 1318727
diff --git a/graphics/jasper/files/patch-CMakeLists.txt b/graphics/jasper/files/patch-CMakeLists.txt
deleted file mode 100644
index 8ca20c39e880..000000000000
--- a/graphics/jasper/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
---- CMakeLists.txt.orig 2019-03-12 18:04:35 UTC
-+++ CMakeLists.txt
-@@ -267,8 +267,8 @@ message("JAS_HAVE_LIBJPEG: ${JAS_HAVE_LIBJPEG}")
- # Check for the OpenGL and GLUT libraries.
- ################################################################################
-
--find_package(OpenGL ${JAS_REQUIRED})
- message("JAS_ENABLE_OPENGL: ${JAS_ENABLE_OPENGL}")
-+find_package(OpenGL ${JAS_OPENGL_REQUIRED})
- message("OpenGL library found: ${OPENGL_FOUND}")
- if (JAS_ENABLE_OPENGL AND OPENGL_FOUND)
- set(JAS_HAVE_OPENGL 0)
diff --git a/graphics/jasper/files/patch-build-cmake-modules-JasOpenGL.cmake b/graphics/jasper/files/patch-build-cmake-modules-JasOpenGL.cmake
new file mode 100644
index 000000000000..dada8cd39136
--- /dev/null
+++ b/graphics/jasper/files/patch-build-cmake-modules-JasOpenGL.cmake
@@ -0,0 +1,11 @@
+--- build/cmake/modules/JasOpenGL.cmake.orig 2020-09-05 14:52:22 UTC
++++ build/cmake/modules/JasOpenGL.cmake
+@@ -4,7 +4,7 @@
+
+ if (JAS_ENABLE_OPENGL)
+ set(OpenGL_GL_PREFERENCE GLVND)
+- find_package(OpenGL ${JAS_REQUIRED})
++ find_package(OpenGL ${JAS_OPENGL_REQUIRED})
+ message("OpenGL library found: ${OPENGL_FOUND}")
+ else()
+ set(OPENGL_FOUND false)
diff --git a/graphics/jasper/pkg-plist b/graphics/jasper/pkg-plist
index 8866a653c476..20e5cc27eb0e 100644
--- a/graphics/jasper/pkg-plist
+++ b/graphics/jasper/pkg-plist
@@ -3,6 +3,7 @@ bin/imginfo
bin/jasper
%%OPENGL%%bin/jiv
include/jasper/jas_cm.h
+include/jasper/jas_compiler.h
include/jasper/jas_config.h
include/jasper/jas_debug.h
include/jasper/jas_dll.h