aboutsummaryrefslogtreecommitdiff
path: root/graphics/jogamp-jogl
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2019-08-14 22:34:30 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2019-08-14 22:34:30 +0000
commit4ff99d99dbcee41a96c89714832af5fb8bcd85c1 (patch)
tree84687f6804f20b6d2b710feb06bba619ef27410c /graphics/jogamp-jogl
parentb4630e9b328d710db1ccd21f1e39df7d7cc63e0d (diff)
downloadports-4ff99d99dbcee41a96c89714832af5fb8bcd85c1.tar.gz
ports-4ff99d99dbcee41a96c89714832af5fb8bcd85c1.zip
graphics/jogamp-jogl:
- Update to 2.3.2 PR: 225058 Submitted by: Ruediger Gad
Notes
Notes: svn path=/head/; revision=508977
Diffstat (limited to 'graphics/jogamp-jogl')
-rw-r--r--graphics/jogamp-jogl/Makefile17
-rw-r--r--graphics/jogamp-jogl/distinfo11
-rw-r--r--graphics/jogamp-jogl/files/patch-gluegen215
3 files changed, 22 insertions, 21 deletions
diff --git a/graphics/jogamp-jogl/Makefile b/graphics/jogamp-jogl/Makefile
index 951453cf4fe6..28a43ffb8306 100644
--- a/graphics/jogamp-jogl/Makefile
+++ b/graphics/jogamp-jogl/Makefile
@@ -2,33 +2,29 @@
# $FreeBSD$
PORTNAME= jogamp-jogl
-PORTVERSION= 2.2.4
-PORTREVISION= 8
+PORTVERSION= 2.3.2
CATEGORIES= graphics devel java
MASTER_SITES= http://jogamp.org/deployment/jogamp-current/archive/Sources/ \
http://jogamp.org/deployment/v${PORTVERSION}/archive/Sources/
-DISTFILES= jogl-v${PORTVERSION}.tar.7z \
- gluegen-v${PORTVERSION}.tar.7z
+DISTFILES= jogl-v${PORTVERSION}.tar.xz \
+ gluegen-v${PORTVERSION}.tar.xz \
+ jcpp-v${PORTVERSION}.tar.xz
MAINTAINER= makc@FreeBSD.org
COMMENT= Java bindings for OpenGL
-EXTRACT_DEPENDS= ${7Z_CMD}:archivers/p7zip
BUILD_DEPENDS= ${JAVALIBDIR}/swt.jar:x11-toolkits/swt
RUN_DEPENDS= ${JAVALIBDIR}/swt.jar:x11-toolkits/swt
ONLY_FOR_ARCHS= i386 amd64
+USES= tar:xz
+
USE_ANT= yes
USE_GCC= yes
USE_JAVA= yes
USE_XORG= x11 xcursor xrandr xrender xxf86vm
-7Z_CMD= ${LOCALBASE}/bin/7z
-EXTRACT_CMD= ${7Z_CMD}
-EXTRACT_BEFORE_ARGS= x -so
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
-
PATCH_WRKSRC= ${WRKDIR}
BUILD_WRKSRC= ${WRKDIR}/jogl/make
BUILD_BINPATH= ${WRKSRC}/bin
@@ -36,6 +32,7 @@ MAKE_ENV+= PATH="${BUILD_BINPATH}:${PATH}"
post-extract:
${MV} ${WRKDIR}/gluegen-v${PORTVERSION} ${WRKDIR}/gluegen
+ ${MV} ${WRKDIR}/jcpp-v${PORTVERSION}/src ${WRKDIR}/gluegen/jcpp/src
${MV} ${WRKDIR}/jogl-v${PORTVERSION} ${WRKDIR}/jogl
${MKDIR} ${BUILD_BINPATH}
${LN} -sf ${LOCALBASE}/bin/${CC} ${BUILD_BINPATH}/gcc
diff --git a/graphics/jogamp-jogl/distinfo b/graphics/jogamp-jogl/distinfo
index 790d3d0fce54..16cd4007b9db 100644
--- a/graphics/jogamp-jogl/distinfo
+++ b/graphics/jogamp-jogl/distinfo
@@ -1,4 +1,7 @@
-SHA256 (jogl-v2.2.4.tar.7z) = 39d53fc4c4c3f8e3a5287646bc10457cfaa6fcc88f07c0b0c7817a95cb1f282b
-SIZE (jogl-v2.2.4.tar.7z) = 33454202
-SHA256 (gluegen-v2.2.4.tar.7z) = 6ad7b35f7c8fc81ec57d986f54b93c5c93127cd6c2b0efc2fb3950022feb15da
-SIZE (gluegen-v2.2.4.tar.7z) = 39334025
+TIMESTAMP = 1565821971
+SHA256 (jogl-v2.3.2.tar.xz) = 88cd468a1401ac6e32f6fb850b59328aff6808ddfa0a579fae53e2fe3b446c06
+SIZE (jogl-v2.3.2.tar.xz) = 35467924
+SHA256 (gluegen-v2.3.2.tar.xz) = d235d5d4c9b8e17d9029be2d9b9e3f2839a67f4f23dd3871fe10c4b5f04091d3
+SIZE (gluegen-v2.3.2.tar.xz) = 64053832
+SHA256 (jcpp-v2.3.2.tar.xz) = 67f889200e438789b2987d4e6c876a1ad6b8cfe3d5cb07a5f9de0d250ab73c46
+SIZE (jcpp-v2.3.2.tar.xz) = 39024
diff --git a/graphics/jogamp-jogl/files/patch-gluegen2 b/graphics/jogamp-jogl/files/patch-gluegen2
index 1368dcb0ec1f..b67615bfde3c 100644
--- a/graphics/jogamp-jogl/files/patch-gluegen2
+++ b/graphics/jogamp-jogl/files/patch-gluegen2
@@ -9,8 +9,8 @@
<condition property="output.lib.name.os" value="lib${output.lib.name}.so"><isset property="isUnix"/></condition>
<condition property="output.lib.name.os" value="${output.lib.name}.dll"><isset property="isWindows"/></condition>
<condition property="output.lib.name.os" value="lib${output.lib.name}.jnilib"><isset property="isOSX"/></condition>
-@@ -604,14 +604,14 @@
- <srcfiles dir= "${src.java}" includes="**"/>
+@@ -605,7 +605,7 @@
+ <srcfiles dir= "${src.jcpp}" includes="**"/>
<srcfiles dir= "${c.grammar}" includes="*.g"/>
<srcfiles dir= "${j.grammar}" includes="*.g"/>
- <mapper type="merge" to="${build}/gluegen.jar"/>
@@ -18,7 +18,8 @@
</uptodate>
<uptodate property="gluegen.build.skip.java2">
<srcfiles dir= "." includes="*.xml"/>
- <srcfiles dir= "${src.java}" includes="**"/>
+@@ -613,7 +613,7 @@
+ <srcfiles dir= "${src.jcpp}" includes="**"/>
<srcfiles dir= "${c.grammar}" includes="*.g"/>
<srcfiles dir= "${j.grammar}" includes="*.g"/>
- <mapper type="merge" to="${build}/gluegen-rt.jar"/>
@@ -57,14 +58,14 @@
// static initialization order:
--- gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java.orig 2014-10-10 13:20:51 UTC
+++ gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java
-@@ -197,8 +197,8 @@ public class TestTempJarCache extends Ju
+@@ -196,8 +196,8 @@ public class TestTempJarCache extends SingletonJunitCase {
@Test
public void testTempJarCache02AddNativeLibs() throws IOException, IllegalArgumentException, URISyntaxException {
if(AndroidVersion.isAvailable) { System.err.println("n/a on Android"); return; }
-- final String nativeJarName = "gluegen-rt-natives-"+Platform.getOSAndArch()+".jar";
+- final Uri.Encoded nativeJarName = Uri.Encoded.cast("gluegen-rt-natives-"+Platform.getOSAndArch()+".jar");
- final String libBaseName = "gluegen-rt";
-+ final String nativeJarName = "gluegen2-rt-natives-"+Platform.getOSAndArch()+".jar";
++ final Uri.Encoded nativeJarName = Uri.Encoded.cast("gluegen2-rt-natives-"+Platform.getOSAndArch()+".jar");
+ final String libBaseName = "gluegen2-rt";
final ClassLoader cl = getClass().getClassLoader();
- URI jarUriRoot = JarUtil.getJarSubURI(TempJarCache.class.getName(), cl);
+ final Uri jarUri = JarUtil.getJarUri(TempJarCache.class.getName(), cl);