aboutsummaryrefslogtreecommitdiff
path: root/graphics/jp
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-08-08 09:57:32 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-08-08 09:57:32 +0000
commit8ac02d7204fdf40c692d73e755a658cdf6697db3 (patch)
tree3cea6aa7aa62ffae06944ae86e944efba3f79854 /graphics/jp
parentb51c1c61fb38ef3d3341d4a88c4802809ca7c265 (diff)
downloadports-8ac02d7204fdf40c692d73e755a658cdf6697db3.tar.gz
ports-8ac02d7204fdf40c692d73e755a658cdf6697db3.zip
graphics/jp: Terminal charts, plots, histograms and maps from JSON and CSV
jp is a dead simple terminal plots from JSON (or CSV) data. Bar charts, line charts, scatter plots, histograms and heatmaps are supported. It reads data on stdin and prints plots to stdout. WWW: https://github.com/sgreben/jp PR: 227271
Notes
Notes: svn path=/head/; revision=508370
Diffstat (limited to 'graphics/jp')
-rw-r--r--graphics/jp/Makefile31
-rw-r--r--graphics/jp/distinfo3
-rw-r--r--graphics/jp/pkg-descr5
-rw-r--r--graphics/jp/pkg-plist13
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/jp/Makefile b/graphics/jp/Makefile
new file mode 100644
index 000000000000..40314c7ba04a
--- /dev/null
+++ b/graphics/jp/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= jp
+DISTVERSION= 1.1.12
+CATEGORIES= graphics
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Terminal charts, plots, histograms and maps from JSON and CSV
+
+LICENSE= MIT APACHE20
+LICENSE_COMB= multi
+
+USES= go
+USE_GITHUB= yes
+GH_ACCOUNT= sgreben
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}/cmd/${PORTNAME}
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} "README.md docs" ${STAGEDIR}${DOCSDIR})
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/graphics/jp/distinfo b/graphics/jp/distinfo
new file mode 100644
index 000000000000..6b06ae6c17d1
--- /dev/null
+++ b/graphics/jp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565253325
+SHA256 (sgreben-jp-1.1.12_GH0.tar.gz) = 8c9cddf8b9d9bfae72be448218ca0e18d24e755d36c915842b12398fefdc7a64
+SIZE (sgreben-jp-1.1.12_GH0.tar.gz) = 1301104
diff --git a/graphics/jp/pkg-descr b/graphics/jp/pkg-descr
new file mode 100644
index 000000000000..0f14af6f8e8b
--- /dev/null
+++ b/graphics/jp/pkg-descr
@@ -0,0 +1,5 @@
+jp is a dead simple terminal plots from JSON (or CSV) data. Bar charts, line
+charts, scatter plots, histograms and heatmaps are supported. It reads data on
+stdin and prints plots to stdout.
+
+WWW: https://github.com/sgreben/jp
diff --git a/graphics/jp/pkg-plist b/graphics/jp/pkg-plist
new file mode 100644
index 000000000000..c04164a91283
--- /dev/null
+++ b/graphics/jp/pkg-plist
@@ -0,0 +1,13 @@
+bin/jp
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/docs/bar_chart.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/bar_chart_full_escape.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/hist2d_full_escape.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/line_chart.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/scatter_plot.png
+%%PORTDOCS%%%%DOCSDIR%%/docs/sin.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eth.csv
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mvrnorm.json
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sin.csv
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sin.json
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp-time.json