aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpeg-turbo
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-06-01 19:13:39 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-06-01 19:13:39 +0000
commit163ab3de6acc2808aa3407f9a651224f5ef50df5 (patch)
tree80751b4210defe5df86a9e6a487ae3d21e6cda18 /graphics/jpeg-turbo
parent382afb1e138c44b66aaee419f92fb780d6a216a8 (diff)
downloadports-163ab3de6acc2808aa3407f9a651224f5ef50df5.tar.gz
ports-163ab3de6acc2808aa3407f9a651224f5ef50df5.zip
- Update to 1.4.0
- Allow building on non i386/amd64 [1] PR: 200095 Approved by: maintainer timeout (3 weeks) Tested on: ia64 and sparc64 [1]
Notes
Notes: svn path=/head/; revision=388256
Diffstat (limited to 'graphics/jpeg-turbo')
-rw-r--r--graphics/jpeg-turbo/Makefile17
-rw-r--r--graphics/jpeg-turbo/distinfo4
-rw-r--r--graphics/jpeg-turbo/files/patch-jchuff.c20
-rw-r--r--graphics/jpeg-turbo/files/patch-md5_md5.c11
-rw-r--r--graphics/jpeg-turbo/pkg-plist2
5 files changed, 24 insertions, 30 deletions
diff --git a/graphics/jpeg-turbo/Makefile b/graphics/jpeg-turbo/Makefile
index 3552578e0c70..368408a90abe 100644
--- a/graphics/jpeg-turbo/Makefile
+++ b/graphics/jpeg-turbo/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= jpeg-turbo
-PORTVERSION= 1.3.1
-PORTREVISION?= 2
+PORTVERSION= 1.4.0
+PORTREVISION?= 0
CATEGORIES= graphics
MASTER_SITES= SF/lib${PORTNAME}/${PORTVERSION}
DISTNAME= lib${PORTNAME}-${PORTVERSION}
@@ -11,9 +11,6 @@ DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= bytestore@yandex.ru
COMMENT?= SIMD-accelerated JPEG codec which replaces libjpeg
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-
-ONLY_FOR_ARCHS= amd64 i386
USES= cpe libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jpeg8
@@ -34,11 +31,17 @@ DOCS_MAKE_ARGS_OFF= dist_doc_DATA=""
EXAMPLES_MAKE_ARGS= exampledir="${EXAMPLESDIR}"
EXAMPLES_MAKE_ARGS_OFF= dist_example_DATA=""
-.if defined(SLAVE_PORT)
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386 || ${ARCH} == amd64
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+.endif
+
+.if ${SLAVE_PORT} == yes
CONFIGURE_ARGS+=--with-pic
PLIST_SUB+= JPEG="@comment " LIBTURBOJPEG=""
.else
-CONFIGURE_ARGS+=--program-suffix=-turbo --without-libturbojpeg
+CONFIGURE_ARGS+=--program-suffix=-turbo --without-turbojpeg
PLIST_SUB+= JPEG="" LIBTURBOJPEG="@comment "
post-install:
diff --git a/graphics/jpeg-turbo/distinfo b/graphics/jpeg-turbo/distinfo
index 026a871df6b7..b078f650ccfd 100644
--- a/graphics/jpeg-turbo/distinfo
+++ b/graphics/jpeg-turbo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libjpeg-turbo-1.3.1.tar.gz) = c132907417ddc40ed552fe53d6b91d5fecbb14a356a60ddc7ea50d6be9666fb9
-SIZE (libjpeg-turbo-1.3.1.tar.gz) = 1390282
+SHA256 (libjpeg-turbo-1.4.0.tar.gz) = d93ad8546b510244f863b39b4c0da0fa4c0d53a77b61a8a3880f258c232bbbee
+SIZE (libjpeg-turbo-1.4.0.tar.gz) = 1524645
diff --git a/graphics/jpeg-turbo/files/patch-jchuff.c b/graphics/jpeg-turbo/files/patch-jchuff.c
deleted file mode 100644
index b636db44c5e1..000000000000
--- a/graphics/jpeg-turbo/files/patch-jchuff.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- jchuff.c.orig 2013-09-28 03:23:49 UTC
-+++ jchuff.c
-@@ -391,7 +391,16 @@ dump_buffer (working_state * state)
- #endif
-
-
--#define BUFSIZE (DCTSIZE2 * 2)
-+/* Although it is exceedingly rare, it is possible for a Huffman-encoded
-+ * coefficient block to be larger than the 128-byte unencoded block. For each
-+ * of the 64 coefficients, PUT_BITS is invoked twice, and each invocation can
-+ * theoretically store 16 bits (for a maximum of 2048 bits or 256 bytes per
-+ * encoded block.) If, for instance, one artificially sets the AC
-+ * coefficients to alternating values of 32767 and -32768 (using the JPEG
-+ * scanning order-- 1, 8, 16, etc.), then this will produce an encoded block
-+ * larger than 200 bytes.
-+ */
-+#define BUFSIZE (DCTSIZE2 * 4)
-
- #define LOAD_BUFFER() { \
- if (state->free_in_buffer < BUFSIZE) { \
diff --git a/graphics/jpeg-turbo/files/patch-md5_md5.c b/graphics/jpeg-turbo/files/patch-md5_md5.c
new file mode 100644
index 000000000000..3495ee0e272d
--- /dev/null
+++ b/graphics/jpeg-turbo/files/patch-md5_md5.c
@@ -0,0 +1,11 @@
+--- md5/md5.c.orig 2014-08-30 13:52:09 UTC
++++ md5/md5.c
+@@ -45,6 +45,8 @@ static void MD5Transform(unsigned int [4
+ #include <libkern/OSByteOrder.h>
+ #define le32toh(x) OSSwapLittleToHostInt32(x)
+ #define htole32(x) OSSwapHostToLittleInt32(x)
++#elif defined(__FreeBSD__)
++#include <sys/endian.h>
+ #endif
+
+ /*
diff --git a/graphics/jpeg-turbo/pkg-plist b/graphics/jpeg-turbo/pkg-plist
index bc57a4b58bd6..032d3d99f49c 100644
--- a/graphics/jpeg-turbo/pkg-plist
+++ b/graphics/jpeg-turbo/pkg-plist
@@ -23,4 +23,4 @@
%%LIBTURBOJPEG%%lib/libturbojpeg.a
%%LIBTURBOJPEG%%lib/libturbojpeg.so
%%LIBTURBOJPEG%%lib/libturbojpeg.so.0
-%%LIBTURBOJPEG%%lib/libturbojpeg.so.0.0.0
+%%LIBTURBOJPEG%%lib/libturbojpeg.so.0.1.0