aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpeg-turbo
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-10-14 16:52:20 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-10-14 16:52:20 +0000
commit171a1f6dee63474274c0236a9293a8d7cbb93956 (patch)
treebd44fe1e468543e460c6694bbf46027dfc8e0509 /graphics/jpeg-turbo
parent869e1f27d0cd912f612cd1af8dd5491749901f80 (diff)
downloadports-171a1f6dee63474274c0236a9293a8d7cbb93956.tar.gz
ports-171a1f6dee63474274c0236a9293a8d7cbb93956.zip
Update to 1.4.2
PR: 203634
Notes
Notes: svn path=/head/; revision=399279
Diffstat (limited to 'graphics/jpeg-turbo')
-rw-r--r--graphics/jpeg-turbo/Makefile2
-rw-r--r--graphics/jpeg-turbo/distinfo4
-rw-r--r--graphics/jpeg-turbo/files/patch-jcdctmgr.c41
3 files changed, 3 insertions, 44 deletions
diff --git a/graphics/jpeg-turbo/Makefile b/graphics/jpeg-turbo/Makefile
index 2a7108973f4f..536cbe895567 100644
--- a/graphics/jpeg-turbo/Makefile
+++ b/graphics/jpeg-turbo/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= jpeg-turbo
-PORTVERSION= 1.4.1
+PORTVERSION= 1.4.2
PORTREVISION?= 0
CATEGORIES= graphics
MASTER_SITES= SF/lib${PORTNAME}/${PORTVERSION}
diff --git a/graphics/jpeg-turbo/distinfo b/graphics/jpeg-turbo/distinfo
index bfc3fdd1b887..f55f5f8c3372 100644
--- a/graphics/jpeg-turbo/distinfo
+++ b/graphics/jpeg-turbo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libjpeg-turbo-1.4.1.tar.gz) = 4bf5bad4ce85625bffbbd9912211e06790e00fb982b77724af7211034efafb08
-SIZE (libjpeg-turbo-1.4.1.tar.gz) = 1529614
+SHA256 (libjpeg-turbo-1.4.2.tar.gz) = 521bb5d3043e7ac063ce3026d9a59cc2ab2e9636c655a2515af5f4706122233e
+SIZE (libjpeg-turbo-1.4.2.tar.gz) = 1569306
diff --git a/graphics/jpeg-turbo/files/patch-jcdctmgr.c b/graphics/jpeg-turbo/files/patch-jcdctmgr.c
deleted file mode 100644
index aed62bdac9c6..000000000000
--- a/graphics/jpeg-turbo/files/patch-jcdctmgr.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- jcdctmgr.c.orig 2014-11-06 09:32:38 UTC
-+++ jcdctmgr.c
-@@ -6,7 +6,7 @@
- * libjpeg-turbo Modifications:
- * Copyright (C) 1999-2006, MIYASAKA Masaru.
- * Copyright 2009 Pierre Ossman <ossman@cendio.se> for Cendio AB
-- * Copyright (C) 2011, 2014 D. R. Commander
-+ * Copyright (C) 2011, 2014-2015 D. R. Commander
- * For conditions of distribution and use, see the accompanying README file.
- *
- * This file contains the forward-DCT management logic.
-@@ -175,6 +175,19 @@ compute_reciprocal (UINT16 divisor, DCTE
- UDCTELEM c;
- int b, r;
-
-+ if (divisor == 1) {
-+ /* divisor == 1 means unquantized, so these reciprocal/correction/shift
-+ * values will cause the C quantization algorithm to act like the
-+ * identity function. Since only the C quantization algorithm is used in
-+ * these cases, the scale value is irrelevant.
-+ */
-+ dtbl[DCTSIZE2 * 0] = (DCTELEM) 1; /* reciprocal */
-+ dtbl[DCTSIZE2 * 1] = (DCTELEM) 0; /* correction */
-+ dtbl[DCTSIZE2 * 2] = (DCTELEM) 1; /* scale */
-+ dtbl[DCTSIZE2 * 3] = (DCTELEM) (-sizeof(DCTELEM) * 8); /* shift */
-+ return 0;
-+ }
-+
- b = flss(divisor) - 1;
- r = sizeof(DCTELEM) * 8 + b;
-
-@@ -395,7 +408,8 @@ quantize (JCOEFPTR coef_block, DCTELEM *
-
- #if BITS_IN_JSAMPLE == 8
-
-- UDCTELEM recip, corr, shift;
-+ UDCTELEM recip, corr;
-+ int shift;
- UDCTELEM2 product;
-
- for (i = 0; i < DCTSIZE2; i++) {