aboutsummaryrefslogtreecommitdiff
path: root/graphics/jslice
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-12 14:32:47 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-12 14:32:47 +0000
commite9e43bd953efc48d9786da907c405666c54d4095 (patch)
treef5de3b923a68c54141b308c2bab9ca7d3c866881 /graphics/jslice
parent9edb68a83e1b05e37cbad236dd2ee25d50f787c3 (diff)
downloadports-e9e43bd953efc48d9786da907c405666c54d4095.tar.gz
ports-e9e43bd953efc48d9786da907c405666c54d4095.zip
Add jslice, a graphics utility which breaks up a JPEG image into slices
and provides HTML code referring the slices.
Notes
Notes: svn path=/head/; revision=30514
Diffstat (limited to 'graphics/jslice')
-rw-r--r--graphics/jslice/Makefile20
-rw-r--r--graphics/jslice/distinfo1
-rw-r--r--graphics/jslice/files/patch-aa15
-rw-r--r--graphics/jslice/pkg-comment1
-rw-r--r--graphics/jslice/pkg-descr6
-rw-r--r--graphics/jslice/pkg-plist1
6 files changed, 44 insertions, 0 deletions
diff --git a/graphics/jslice/Makefile b/graphics/jslice/Makefile
new file mode 100644
index 000000000000..bb875532983d
--- /dev/null
+++ b/graphics/jslice/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: insert
+# Date created: Wed 12 Jul 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= jslice
+PORTVERSION= 1.0.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.pldaniels.com/jslice/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/jslice ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/jslice/distinfo b/graphics/jslice/distinfo
new file mode 100644
index 000000000000..c12a8595af86
--- /dev/null
+++ b/graphics/jslice/distinfo
@@ -0,0 +1 @@
+MD5 (jslice-1.0.0.tar.gz) = 90dad1b811fdf23af5e6f7e2fed1ac3a
diff --git a/graphics/jslice/files/patch-aa b/graphics/jslice/files/patch-aa
new file mode 100644
index 000000000000..82d7a63176c2
--- /dev/null
+++ b/graphics/jslice/files/patch-aa
@@ -0,0 +1,15 @@
+--- Makefile Wed May 31 12:39:28 2000
++++ Makefile.new Wed Jul 12 10:23:42 2000
+@@ -1,5 +1,11 @@
++LOCALBASE ?= /usr/local
++CC ?= cc
++INC ?= -I$(LOCALBASE)/include
++LIB ?= -L$(LOCALBASE)/lib
++CFLAGS ?= -O -pipe
++
+ all:
+- gcc jslice.c -o jslice -Wall -ljpeg
++ $(CC) $(CFLAGS) $(INC) $(LIB) jslice.c -o jslice -Wall -ljpeg
+
+ install:
+ cp jslice /usr/local/bin
diff --git a/graphics/jslice/pkg-comment b/graphics/jslice/pkg-comment
new file mode 100644
index 000000000000..68e7a57e9360
--- /dev/null
+++ b/graphics/jslice/pkg-comment
@@ -0,0 +1 @@
+Graphics tool to split up a JPEG image and provide HTML for the slices
diff --git a/graphics/jslice/pkg-descr b/graphics/jslice/pkg-descr
new file mode 100644
index 000000000000..50daf3def0ec
--- /dev/null
+++ b/graphics/jslice/pkg-descr
@@ -0,0 +1,6 @@
+Jslice takes a single JPEG picture and slices it up into a
+table to facilitate the activation of various portions of
+the original picture in an HTML document.
+
+WWW: http://www.pldaniels.com/jslice/
+Author: Paul L. Daniels <pldaniels@pldaniels.com>
diff --git a/graphics/jslice/pkg-plist b/graphics/jslice/pkg-plist
new file mode 100644
index 000000000000..f522fdc82910
--- /dev/null
+++ b/graphics/jslice/pkg-plist
@@ -0,0 +1 @@
+bin/jslice