aboutsummaryrefslogtreecommitdiff
path: root/graphics/kamera-kde4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
commite9c34f4c34b0640b3613f03cd96e9f19730b2a07 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /graphics/kamera-kde4
parent4dc7ccc95d370549c7c9c7c9c253d64aa92881ae (diff)
downloadports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.tar.gz
ports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.zip
Notes
Diffstat (limited to 'graphics/kamera-kde4')
-rw-r--r--graphics/kamera-kde4/Makefile8
-rw-r--r--graphics/kamera-kde4/distinfo4
-rw-r--r--graphics/kamera-kde4/files/patch-git_1b10fdf61
3 files changed, 3 insertions, 70 deletions
diff --git a/graphics/kamera-kde4/Makefile b/graphics/kamera-kde4/Makefile
index c5ca56a2b34f..04c9ae999cdf 100644
--- a/graphics/kamera-kde4/Makefile
+++ b/graphics/kamera-kde4/Makefile
@@ -3,23 +3,17 @@
PORTNAME= kamera
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= graphics kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Digital camera manager for KDE 4
-LATEST_LINK= ${PORTNAME}-kde4
-
LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
-CONFLICTS= kdegraphics-4.[0-6].*
-
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/graphics/kamera-kde4/distinfo b/graphics/kamera-kde4/distinfo
index f636b9e56aac..1e0b78dd3b65 100644
--- a/graphics/kamera-kde4/distinfo
+++ b/graphics/kamera-kde4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/kamera-4.10.5.tar.xz) = c177234e51cbeb70994da360afce2373709389d921d001d61c7645c06c50138f
-SIZE (KDE/4.10.5/kamera-4.10.5.tar.xz) = 37760
+SHA256 (KDE/4.12.2/kamera-4.12.2.tar.xz) = df6e59a573c3083c311dd5130ab7fde64592858d5ef0035c7ec68548d381b5df
+SIZE (KDE/4.12.2/kamera-4.12.2.tar.xz) = 35276
diff --git a/graphics/kamera-kde4/files/patch-git_1b10fdf b/graphics/kamera-kde4/files/patch-git_1b10fdf
deleted file mode 100644
index a2b81bb61334..000000000000
--- a/graphics/kamera-kde4/files/patch-git_1b10fdf
+++ /dev/null
@@ -1,61 +0,0 @@
-commit 1b10fdfc22646ea08683a881648989ef16d61dd1
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Mon Jan 20 14:16:47 2014 +0200
-
- cmake: Correctly check for gp_port_info_get_name.
-
- CHECK_LIBRARY_EXISTS() is the wrong function to call here; we've already
- looked for gphoto's librares in FindGphoto2.cmake. Instead, we are
- interested in knowing whether the symbol gp_port_info_get_name is present in
- the libraries, since this indicates we have gphoto >= 2.5.0.
-
- Additionally, we must also set CMAKE_REQUIRED_{INCLUDES,LIBRARIES} to take
- into account the gphoto header and library paths we have found, otherwise
- we're just relying on them being in the compiler/linker's default paths.
-
- While here, also set HAVE_GPHOTO2_5 directly instead of setting GPHOTO2_5
- and then using its value to set the former.
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ebae998..08d3b0e 100644
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -1,25 +1,28 @@
- project(kamera)
-
- find_package(KDE4 REQUIRED)
-+include(CMakePushCheckState)
-+include(CheckSymbolExists)
- include(KDE4Defaults)
- include(MacroLibrary)
- include(MacroOptionalAddSubdirectory)
--
-
- find_package(Gphoto2)
- macro_log_feature(GPHOTO2_FOUND "gphoto2" "Required to build kamera" "http://heanet.dl.sourceforge.net/sourceforge/gphoto" TRUE "" "")
-
--check_library_exists(gphoto2_port gp_port_info_get_name "" GPHOTO2_5)
--if(GPHOTO2_5)
-- message(STATUS "Found libgphoto 2.5")
--else(GPHOTO2_5)
-- message(STATUS "libgphoto 2.5 not found, assuming libgphoto2 2.4")
--endif(GPHOTO2_5)
--set(HAVE_GPHOTO2_5 ${GPHOTO2_5})
--
--include(ConfigureChecks.cmake)
-+cmake_push_check_state()
-+set(CMAKE_REQUIRED_INCLUDES "${GPHOTO2_INCLUDE_DIR}")
-+set(CMAKE_REQUIRED_LIBRARIES "${GPHOTO2_LIBRARIES}")
-+check_symbol_exists(gp_port_info_get_name "gphoto2.h" HAVE_GPHOTO2_5)
-+cmake_pop_check_state()
-
-+if(HAVE_GPHOTO2_5)
-+ message(STATUS "Detected libgphoto 2.5.0 or newer")
-+else()
-+ message(STATUS "Detected libgphoto2 2.4 or older")
-+endif()
-
-+include(ConfigureChecks.cmake)
-
- configure_file(config-kamera.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-kamera.h)
-