aboutsummaryrefslogtreecommitdiff
path: root/graphics/kimageannotator
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-04-16 15:23:01 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-04-16 15:23:01 +0000
commit5af0d0c108577a0b01408140bdfcaa68980428f1 (patch)
tree58b29ff1c8dda9bef99018d01cb25242b8e861d6 /graphics/kimageannotator
parent94a3437c9b23ca280793db2a3540dda93aff7b0f (diff)
Notes
Diffstat (limited to 'graphics/kimageannotator')
-rw-r--r--graphics/kimageannotator/Makefile25
-rw-r--r--graphics/kimageannotator/distinfo5
-rw-r--r--graphics/kimageannotator/files/patch-CMakeLists.txt20
-rw-r--r--graphics/kimageannotator/pkg-descr3
-rw-r--r--graphics/kimageannotator/pkg-plist8
5 files changed, 61 insertions, 0 deletions
diff --git a/graphics/kimageannotator/Makefile b/graphics/kimageannotator/Makefile
new file mode 100644
index 000000000000..72db48ef71d9
--- /dev/null
+++ b/graphics/kimageannotator/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= kImageAnnotator
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.1
+CATEGORIES= graphics kde
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Tool for annotating images
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libkColorPicker.so:graphics/kcolorpicker
+
+USES= cmake localbase qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= ksnip
+USE_QT= core \
+ buildtools_build qmake_build
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_EXAMPLE
+
+.include <bsd.port.mk>
diff --git a/graphics/kimageannotator/distinfo b/graphics/kimageannotator/distinfo
new file mode 100644
index 000000000000..309e8dccdfd8
--- /dev/null
+++ b/graphics/kimageannotator/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1587049005
+SHA256 (ksnip-kImageAnnotator-v0.2.1_GH0.tar.gz) = 790c4302d56719cf6a05eaf10b2d2baef760fffa29c1a43d0642822526520aed
+SIZE (ksnip-kImageAnnotator-v0.2.1_GH0.tar.gz) = 107027
+SHA256 (643e15e45ef7474f6f4c4b01ee3c3f71ef82f022.patch) = 19a9980f78dffb1bc359791d7797685a21f117d57587b098caaab82e2de3e3cd
+SIZE (643e15e45ef7474f6f4c4b01ee3c3f71ef82f022.patch) = 1137
diff --git a/graphics/kimageannotator/files/patch-CMakeLists.txt b/graphics/kimageannotator/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..338b499ca2ea
--- /dev/null
+++ b/graphics/kimageannotator/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+Obtained from [1] with minor adaption to fix linking against X11
+
+[1] https://github.com/ksnip/kImageAnnotator/pull/85
+
+--- CMakeLists.txt.orig 2020-02-21 21:51:32 UTC
++++ CMakeLists.txt
+@@ -55,10 +55,10 @@ target_include_directories(kImageAnnotator
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
+ )
+
++target_link_libraries(kImageAnnotator PUBLIC Qt5::Widgets PRIVATE kColorPicker::kColorPicker)
++
+ if (UNIX)
+- target_link_libraries(kImageAnnotator PUBLIC Qt5::Widgets kColorPicker X11)
+-else ()
+- target_link_libraries(kImageAnnotator PUBLIC Qt5::Widgets kColorPicker)
++ target_link_libraries(kImageAnnotator PRIVATE X11::X11)
+ endif ()
+
+ target_compile_definitions(kImageAnnotator PRIVATE KIMAGEANNOTATOR_LIB)
diff --git a/graphics/kimageannotator/pkg-descr b/graphics/kimageannotator/pkg-descr
new file mode 100644
index 000000000000..d3c1e5c690c0
--- /dev/null
+++ b/graphics/kimageannotator/pkg-descr
@@ -0,0 +1,3 @@
+Tool for annotating images
+
+WWW: https://github.com/ksnip/kImageAnnotator
diff --git a/graphics/kimageannotator/pkg-plist b/graphics/kimageannotator/pkg-plist
new file mode 100644
index 000000000000..e934f1d26e1c
--- /dev/null
+++ b/graphics/kimageannotator/pkg-plist
@@ -0,0 +1,8 @@
+include/kImageAnnotator/KImageAnnotator.h
+include/kImageAnnotator/KImageAnnotatorExport.h
+lib/cmake/kImageAnnotator/kImageAnnotator-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/kImageAnnotator/kImageAnnotator-targets.cmake
+lib/cmake/kImageAnnotator/kImageAnnotatorConfig-version.cmake
+lib/cmake/kImageAnnotator/kImageAnnotatorConfig.cmake
+lib/libkImageAnnotator.so
+lib/libkImageAnnotator.so.0.2.1