aboutsummaryrefslogtreecommitdiff
path: root/graphics/kphotoalbum-kde4/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-04-19 09:45:59 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-04-19 09:45:59 +0000
commitad7699c582859a99e2995870e9a5191e726c72f4 (patch)
treee0b0f4d78e3ce5bf36eea3a5659616cc3bd4be85 /graphics/kphotoalbum-kde4/Makefile
parentfeb3a2a2e660a73ea78278caa18ce81726a8a191 (diff)
downloadports-ad7699c582859a99e2995870e9a5191e726c72f4.tar.gz
ports-ad7699c582859a99e2995870e9a5191e726c72f4.zip
Notes
Diffstat (limited to 'graphics/kphotoalbum-kde4/Makefile')
-rw-r--r--graphics/kphotoalbum-kde4/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index 1ecb83805cb6..5d2937a91a50 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kphotoalbum
PORTVERSION= ${APP_VER}.${EXTRA_VER}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${EXTRA_VER}/src/extragear
@@ -16,7 +16,9 @@ DIST_SUBDIR= KDE/extragear
MAINTAINER= kde@FreeBSD.org
COMMENT= Image viewer and organizer for KDE
-LIB_DEPENDS= kipi.8:${PORTSDIR}/graphics/kdegraphics4
+LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
+ exiv2.10:${PORTSDIR}/graphics/exiv2 \
+ kipi.8:${PORTSDIR}/graphics/kdegraphics4
USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
@@ -36,12 +38,8 @@ OPTIONS= MARBLE "Geolocation support (requires astro/marble)" off
.if defined(WITH_MARBLE)
LIB_DEPENDS+= marblewidget.11:${PORTSDIR}/astro/marble
-.endif
-
-pre-configure:
-.if !defined(WITH_MARBLE)
- ${REINPLACE_CMD} -e '/macro_optional_find_package(Marble)/d' \
- ${WRKSRC}/CMakeLists.txt
+.else
+CMAKE_ARGS+= -DWITH_Marble:BOOL=Off
.endif
.include <bsd.port.mk>