aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcms
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-10-25 20:14:27 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-10-25 20:14:27 +0000
commit62a3a103b8880a9791d77eec87d16b3fcf0d9372 (patch)
treed4f34728ce2051b30621e05db7d89b2fb4dbf02b /graphics/lcms
parenta359bd06580815d8d79995203613a8b4f147327a (diff)
downloadports-62a3a103b8880a9791d77eec87d16b3fcf0d9372.tar.gz
ports-62a3a103b8880a9791d77eec87d16b3fcf0d9372.zip
Remove the bogus dependency on -ltiff (--without-tiff was always in there).
Make the testcms link the new -lcms statically to avoid possible conflicts with the already installed library (probably of a different version). PR: ports/68610
Notes
Notes: svn path=/head/; revision=120177
Diffstat (limited to 'graphics/lcms')
-rw-r--r--graphics/lcms/Makefile4
-rw-r--r--graphics/lcms/files/patch-test-static9
2 files changed, 9 insertions, 4 deletions
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index 96dac7284794..bd52a0414f98 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -16,13 +16,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Light Color Management System -- a color management library
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
-
USE_GNOME= gnomehack gnometarget lthack
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER= 13
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --without-jpeg --without-tiff
INSTALLS_SHLIB= yes
diff --git a/graphics/lcms/files/patch-test-static b/graphics/lcms/files/patch-test-static
new file mode 100644
index 000000000000..28e3f36fd690
--- /dev/null
+++ b/graphics/lcms/files/patch-test-static
@@ -0,0 +1,9 @@
+--- testbed/Makefile.in Mon Apr 19 12:02:23 2004
++++ testbed/Makefile.in Mon Oct 25 16:07:37 2004
+@@ -198,5 +198,5 @@
+
+ testcms_LDADD = $(top_builddir)/src/liblcms.la
+-testcms_LDFLAGS = @LDFLAGS@
++testcms_LDFLAGS = @LDFLAGS@ -static
+ testcms_SOURCES = testcms.c
+