aboutsummaryrefslogtreecommitdiff
path: root/graphics/lensfun
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/lensfun
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'graphics/lensfun')
-rw-r--r--graphics/lensfun/Makefile4
-rw-r--r--graphics/lensfun/files/patch-image.cpp37
2 files changed, 39 insertions, 2 deletions
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
index 989eabe4133e..a02446d79827 100644
--- a/graphics/lensfun/Makefile
+++ b/graphics/lensfun/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lensfun
PORTVERSION= 0.2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= BERLIOS
@@ -16,7 +16,7 @@ COMMENT= Library for fixing lens geometry distortions
LICENSE= LGPL3
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/graphics/lensfun/files/patch-image.cpp b/graphics/lensfun/files/patch-image.cpp
new file mode 100644
index 000000000000..a5b111788379
--- /dev/null
+++ b/graphics/lensfun/files/patch-image.cpp
@@ -0,0 +1,37 @@
+--- libs/auxfun/image.cpp.orig 2008-05-02 08:56:04.000000000 +0200
++++ libs/auxfun/image.cpp 2012-05-04 12:31:16.000000000 +0200
+@@ -6,6 +6,7 @@
+ #include "image.h"
+ #include <zlib.h>
+ #include <png.h>
++#include <pngpriv.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <math.h>
+@@ -94,7 +95,7 @@
+
+ png_init_io (png, file);
+
+- if (setjmp (png->jmpbuf))
++ if (setjmp (png_jmpbuf(png)))
+ // If we get here, we had a problem reading the file
+ goto nomem;
+
+@@ -157,7 +158,7 @@
+ row_pointers = new png_bytep [Height];
+
+ if (!row_pointers
+- || setjmp (png->jmpbuf)) // Set a new exception handler
++ || setjmp (png_jmpbuf(png))) // Set a new exception handler
+ {
+ delete [] row_pointers;
+ nomem:
+@@ -214,7 +215,7 @@
+ }
+
+ /* Catch processing errors */
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ /* If we get here, we had a problem writing the file */
+ goto error2;
+