aboutsummaryrefslogtreecommitdiff
path: root/graphics/lfview/Makefile
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-07 12:26:01 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-07 12:26:01 +0000
commit6e0804410f6b76df663c2d57218035f781bedb14 (patch)
tree6a9b176a27818eef70bf651e7029d54c0eb272e4 /graphics/lfview/Makefile
parent1850731ae020e04d575acddaa2729dd11ccef564 (diff)
downloadports-6e0804410f6b76df663c2d57218035f781bedb14.tar.gz
ports-6e0804410f6b76df663c2d57218035f781bedb14.zip
PR: 10460
Submitted by: s974123@cc.matsuyama-u.ac.jp Graphic viewer for Leaf products.
Notes
Notes: svn path=/head/; revision=17034
Diffstat (limited to 'graphics/lfview/Makefile')
-rw-r--r--graphics/lfview/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/lfview/Makefile b/graphics/lfview/Makefile
new file mode 100644
index 000000000000..f788acbf31a4
--- /dev/null
+++ b/graphics/lfview/Makefile
@@ -0,0 +1,34 @@
+# ports collection makefile for: lfview
+# Version required: 1.1beta2
+# Date created: 24 February 1999
+# Whom: Yuu Yashiki
+#
+# $Id$
+#
+
+DISTNAME= lfview11beta2
+PKGNAME= lfview-1.1b2
+CATEGORIES= graphics
+MASTER_SITES= http://www.geocities.co.jp/Playtown/6344/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= s974123@cc.matsuyama-u.ac.jp
+
+WRKSRC= ${WRKDIR}/lfview1.1beta2
+USE_IMAKE= yes
+
+NO_INSTALL_MANPAGES= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lfview ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/plugins/liblfv_leaf.so.1 ${PREFIX}/lib
+ ${LN} -s ${WRKSRC}/plugins/liblfv_leaf.so ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ja/lfview
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ja/lfview
+.endif
+
+post-install:
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>