aboutsummaryrefslogtreecommitdiff
path: root/graphics/libGLU/Makefile
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2021-07-15 06:53:16 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-07-15 06:53:16 +0000
commitfac2bc519518fc6072e1d042b12cca44afb63568 (patch)
tree59e70e8de32fd84fb2ba97499209973576f5fbd0 /graphics/libGLU/Makefile
parentd94d5da10640ad4b8d871a9b3e99a70bbd60b0e1 (diff)
Diffstat (limited to 'graphics/libGLU/Makefile')
-rw-r--r--graphics/libGLU/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/libGLU/Makefile b/graphics/libGLU/Makefile
index 3f332cd6d995..82797034880a 100644
--- a/graphics/libGLU/Makefile
+++ b/graphics/libGLU/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libGLU
PORTVERSION= 9.0.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/glu/ \
https://mesa.freedesktop.org/archive/glu/
@@ -10,12 +11,12 @@ DISTNAME= glu-${PORTVERSION}
MAINTAINER= x11@FreeBSD.org
COMMENT= OpenGL utility library
-USES= gl libtool pathfix pkgconfig tar:xz
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-static \
- --enable-libglvnd
-INSTALL_TARGET= install-strip
+USES= gl libtool meson pathfix pkgconfig tar:xz
+
USE_GL= opengl
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+MESON_ARGS= -Ddefault_library=shared
+
.include <bsd.port.mk>