aboutsummaryrefslogtreecommitdiff
path: root/graphics/libQGLViewer
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-18 21:43:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-18 21:43:15 +0000
commit4578d819d3fd586f2500386ccc8f4afe190c2a69 (patch)
treef256b694a1264ad111502724ef279cbd9ce49f9a /graphics/libQGLViewer
parent7a8364fb880fdc4bf7b4d50f0f038929f70961c1 (diff)
downloadports-4578d819d3fd586f2500386ccc8f4afe190c2a69.tar.gz
ports-4578d819d3fd586f2500386ccc8f4afe190c2a69.zip
Notes
Diffstat (limited to 'graphics/libQGLViewer')
-rw-r--r--graphics/libQGLViewer/Makefile26
-rw-r--r--graphics/libQGLViewer/distinfo3
-rw-r--r--graphics/libQGLViewer/files/patch-designerPlugin_designerPlugin.pro11
-rw-r--r--graphics/libQGLViewer/pkg-descr11
-rw-r--r--graphics/libQGLViewer/pkg-plist19
5 files changed, 70 insertions, 0 deletions
diff --git a/graphics/libQGLViewer/Makefile b/graphics/libQGLViewer/Makefile
new file mode 100644
index 000000000000..33937a1e7791
--- /dev/null
+++ b/graphics/libQGLViewer/Makefile
@@ -0,0 +1,26 @@
+# Created by: Yuri Victorovich <yuri@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libQGLViewer
+DISTVERSION= 2.7.1
+CATEGORIES= graphics devel
+MASTER_SITES= http://www.libqglviewer.com/src/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library based on Qt5 that eases the creation of OpenGL 3D viewers
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+USES= qmake
+USE_GL= gl glu
+USE_QT5= core designer gui opengl widgets xml buildtools_build
+USE_LDCONFIG= yes
+PLIST_SUB= SHL3=${DISTVERSION} SHL2=${DISTVERSION:C/\.[0-9]$//} SHL1=${DISTVERSION:C/\.[0-9]\.[0-9]$//}
+
+OPTIONS_DEFINE= DOCS
+
+DOCSDIR= ${PREFIX}/share/doc/QGLViewer
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/graphics/libQGLViewer/distinfo b/graphics/libQGLViewer/distinfo
new file mode 100644
index 000000000000..426e2884370c
--- /dev/null
+++ b/graphics/libQGLViewer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513584996
+SHA256 (libQGLViewer-2.7.1.tar.gz) = bfc7d97e3e8ec8d815e4150896c8a1b65ba4f01b063488f3d64d4e21a607c121
+SIZE (libQGLViewer-2.7.1.tar.gz) = 3078737
diff --git a/graphics/libQGLViewer/files/patch-designerPlugin_designerPlugin.pro b/graphics/libQGLViewer/files/patch-designerPlugin_designerPlugin.pro
new file mode 100644
index 000000000000..4e134ef5ca18
--- /dev/null
+++ b/graphics/libQGLViewer/files/patch-designerPlugin_designerPlugin.pro
@@ -0,0 +1,11 @@
+--- designerPlugin/designerPlugin.pro.orig 2017-12-18 16:48:34 UTC
++++ designerPlugin/designerPlugin.pro
+@@ -20,7 +20,7 @@ QT_VERSION=$$[QT_VERSION]
+ }
+ }
+
+-target.path = $${PREFIX}/designer
++target.path = $${PREFIX}/lib/qt5/plugins/designer
+ INSTALLS += target
+
+ HEADERS = qglviewerPlugin.h
diff --git a/graphics/libQGLViewer/pkg-descr b/graphics/libQGLViewer/pkg-descr
new file mode 100644
index 000000000000..f6a77e712847
--- /dev/null
+++ b/graphics/libQGLViewer/pkg-descr
@@ -0,0 +1,11 @@
+libQGLViewer is a C++ library based on Qt that eases the creation of OpenGL
+3D viewers.
+
+It provides some of the typical 3D viewer functionalities, such as the
+possibility to move the camera using the mouse, which lacks in most of the
+other APIs. Other features include mouse manipulated frames, interpolated
+keyFrames, object selection, stereo display, screenshot saving and much more.
+It can be used by OpenGL beginners as well as to create complex applications,
+being fully customizable and easy to extend.
+
+WWW: http://libqglviewer.com/index.html
diff --git a/graphics/libQGLViewer/pkg-plist b/graphics/libQGLViewer/pkg-plist
new file mode 100644
index 000000000000..29d64671a919
--- /dev/null
+++ b/graphics/libQGLViewer/pkg-plist
@@ -0,0 +1,19 @@
+include/QGLViewer/camera.h
+include/QGLViewer/config.h
+include/QGLViewer/constraint.h
+include/QGLViewer/domUtils.h
+include/QGLViewer/frame.h
+include/QGLViewer/keyFrameInterpolator.h
+include/QGLViewer/manipulatedCameraFrame.h
+include/QGLViewer/manipulatedFrame.h
+include/QGLViewer/mouseGrabber.h
+include/QGLViewer/qglviewer.h
+include/QGLViewer/qglviewer_fr.qm
+include/QGLViewer/quaternion.h
+include/QGLViewer/vec.h
+lib/libQGLViewer-qt5.prl
+lib/libQGLViewer-qt5.so
+lib/libQGLViewer-qt5.so.%%SHL1%%
+lib/libQGLViewer-qt5.so.%%SHL2%%
+lib/libQGLViewer-qt5.so.%%SHL3%%
+lib/qt5/plugins/designer/libqglviewerplugin.so