aboutsummaryrefslogtreecommitdiff
path: root/graphics/libafterimage/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-08 16:28:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-08 16:28:17 +0000
commit79bcfeebd61929ba1e9c3a7dd95b8395c0a109aa (patch)
tree1b1b4114968a8d889731c4baa3e2a799b666184f /graphics/libafterimage/Makefile
parent0b5a840b4839f23d43f0d7229e2385e120ac6058 (diff)
add libafterimage
Generic imaging library originally designed for AfterStep
Notes
Notes: svn path=/head/; revision=48570
Diffstat (limited to 'graphics/libafterimage/Makefile')
-rw-r--r--graphics/libafterimage/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/graphics/libafterimage/Makefile b/graphics/libafterimage/Makefile
new file mode 100644
index 000000000000..9da4e4b7ffa3
--- /dev/null
+++ b/graphics/libafterimage/Makefile
@@ -0,0 +1,48 @@
+# ex:ts=8
+# New ports collection makefile for: libAfterImage
+# Date created: Oct 7, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libafterimage
+PORTVERSION= 0.81
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= afterstep
+DISTNAME= libAfterImage-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png \
+ ungif:${PORTSDIR}/graphics/libungif \
+ tiff:${PORTSDIR}/graphics/tiff \
+ freetype:${PORTSDIR}/print/freetype2 \
+ AfterBase:${PORTSDIR}/devel/libafterbase
+
+USE_X_PREFIX= yes
+FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} `${FREETYPE_CONFIG} --cflags` -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="`${FREETYPE_CONFIG} --libs`"
+CONFIGURE_ARGS= --enable-sharedlibs --with-x
+WRKSRC= ${WRKDIR}/libAfterImage
+INSTALLS_SHLIB= yes
+
+MANCOMPRESSED= no
+MAN3= afterimage.3x asfont.3x asimage.3x asvisual.3x blender.3x import.3x
+
+post-patch:
+ @${PERL} -pi -e "s,\@CFLAGS\@,\@CPPFLAGS\@,g" ${WRKSRC}/Makefile.in
+
+pre-install:
+ @${TOUCH} ${WRKSRC}/doc/export.man
+
+post-install:
+ @${MV} -f ${PREFIX}/lib/libAfterImage.so.0.81 ${PREFIX}/lib/libAfterImage.so.0
+ @${RM} -f ${MAN3PREFIX}/man/man3/export.3x
+
+.include <bsd.port.mk>