aboutsummaryrefslogtreecommitdiff
path: root/graphics/libafterimage
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-24 12:29:30 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-24 12:29:30 +0000
commitbf7c3af700612867d4f369dd661a5e374cc545b5 (patch)
tree52826e8b3b7ecd61380758d47d2632f98592c195 /graphics/libafterimage
parentb6756efc94a89dc7d74e9d88e89995733fc3779a (diff)
downloadports-bf7c3af700612867d4f369dd661a5e374cc545b5.tar.gz
ports-bf7c3af700612867d4f369dd661a5e374cc545b5.zip
Properly support png 1.5
Obtained from: Gentoo
Notes
Notes: svn path=/head/; revision=375450
Diffstat (limited to 'graphics/libafterimage')
-rw-r--r--graphics/libafterimage/Makefile2
-rw-r--r--graphics/libafterimage/files/patch-export.c11
-rw-r--r--graphics/libafterimage/files/patch-import.c19
-rw-r--r--graphics/libafterimage/files/patch-libpng1531
4 files changed, 32 insertions, 31 deletions
diff --git a/graphics/libafterimage/Makefile b/graphics/libafterimage/Makefile
index 140f0dc2d4b4..4e6c3b04c24d 100644
--- a/graphics/libafterimage/Makefile
+++ b/graphics/libafterimage/Makefile
@@ -15,7 +15,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
libfreetype.so:${PORTSDIR}/print/freetype2
diff --git a/graphics/libafterimage/files/patch-export.c b/graphics/libafterimage/files/patch-export.c
deleted file mode 100644
index 950da3b1b275..000000000000
--- a/graphics/libafterimage/files/patch-export.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- export.c.orig 2011-01-15 06:52:22.000000000 +0100
-+++ export.c 2012-05-04 12:57:15.000000000 +0200
-@@ -496,7 +496,7 @@
- png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
- if ( png_ptr != NULL )
- if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
-- if( setjmp(png_ptr->jmpbuf) )
-+ if( setjmp(png_jmpbuf(png_ptr)) )
- {
- png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
- info_ptr = NULL ;
diff --git a/graphics/libafterimage/files/patch-import.c b/graphics/libafterimage/files/patch-import.c
deleted file mode 100644
index 3b2a5f7f8b47..000000000000
--- a/graphics/libafterimage/files/patch-import.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- import.c.orig 2011-01-15 06:52:22.000000000 +0100
-+++ import.c 2012-05-04 18:57:46.000000000 +0200
-@@ -40,6 +40,7 @@
- # else
- # include <png.h>
- # endif
-+# include <pngpriv.h>
- #else
- # include <setjmp.h>
- # ifdef HAVE_JPEG
-@@ -1251,7 +1252,7 @@
- * the normal method of doing things with libpng). REQUIRED unless you
- * set up your own error handlers in the png_create_read_struct() earlier.
- */
-- if ( !setjmp (png_ptr->jmpbuf))
-+ if ( !setjmp (png_jmpbuf(png_ptr)))
- {
- ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
-
diff --git a/graphics/libafterimage/files/patch-libpng15 b/graphics/libafterimage/files/patch-libpng15
new file mode 100644
index 000000000000..44d5b944007c
--- /dev/null
+++ b/graphics/libafterimage/files/patch-libpng15
@@ -0,0 +1,31 @@
+--- export.c
++++ export.c
+@@ -496,7 +496,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
+--- import.c
++++ import.c
+@@ -1251,7 +1251,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+
+@@ -1468,7 +1468,7 @@
+
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
+ memcpy(data, buf->buffer, length);
+ buf->buffer += length;
+ }