aboutsummaryrefslogtreecommitdiff
path: root/graphics/libchamplain/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-11 16:07:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-11 16:07:32 +0000
commit19a859d72326bd50f0a0dacaa9330c39a2fe4d30 (patch)
tree995825d4b53c0c53864ab32a345bd83dca23b758 /graphics/libchamplain/Makefile
parent378fcc65e5c6084bab378ea6c3225f14295a6a30 (diff)
Notes
Diffstat (limited to 'graphics/libchamplain/Makefile')
-rw-r--r--graphics/libchamplain/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/graphics/libchamplain/Makefile b/graphics/libchamplain/Makefile
index 9eecd073fe50..3445321c911f 100644
--- a/graphics/libchamplain/Makefile
+++ b/graphics/libchamplain/Makefile
@@ -4,31 +4,28 @@
PORTNAME= libchamplain
PORTVERSION= 0.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A C library provides a Gtk+ widget to display rasterized maps/markers
+COMMENT= C library provides a Gtk+ widget to display rasterized maps/markers
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS= clutter-gtk-0.10:${PORTSDIR}/graphics/clutter-gtk \
- soup-gnome-2.4:${PORTSDIR}/devel/libsoup-gnome
+LIB_DEPENDS= libclutter-gtk-0.10.so:${PORTSDIR}/graphics/clutter-gtk \
+ libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
RUN_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-USE_BZIP2= yes
-USES= pathfix pkgconfig
-USE_GNOME= gnomeprefix gtk20 ltverhack:1
+USES= gmake libtool pathfix pkgconfig tar:bzip2
+USE_GNOME= gnomeprefix gtk20
USE_SQLITE= 3
-USE_AUTOTOOLS= libtool
USE_GL= gl
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lgthread-2.0
+INSTALL_TARGET= install-strip
PLIST_SUB= VERSION=0.8
-NO_STAGE= yes
.include <bsd.port.mk>