aboutsummaryrefslogtreecommitdiff
path: root/graphics/libetonyek01/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 09:47:55 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 09:47:55 +0000
commite041eaf406e3f85cfd1379c5e9dbcda987ddaa9a (patch)
treec5a31f31f80879f4d30bd42c7723913f5e9b1de2 /graphics/libetonyek01/Makefile
parenta32ac3883f64087535d85784178111ed3d7c0ce9 (diff)
downloadports-e041eaf406e3f85cfd1379c5e9dbcda987ddaa9a.tar.gz
ports-e041eaf406e3f85cfd1379c5e9dbcda987ddaa9a.zip
Notes
Diffstat (limited to 'graphics/libetonyek01/Makefile')
-rw-r--r--graphics/libetonyek01/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/graphics/libetonyek01/Makefile b/graphics/libetonyek01/Makefile
new file mode 100644
index 000000000000..a4b2cde2d658
--- /dev/null
+++ b/graphics/libetonyek01/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= libetonyek
+PORTVERSION= 0.1.1
+CATEGORIES= graphics
+MASTER_SITES= http://dev-www.libreoffice.org/src/
+PKGNAMESUFFIX= 01
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library to interpret and import Apple Keynote presentations
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+USES= gperf
+LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ librevenge-0.0.so:${PORTSDIR}/textproc/librevenge \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
+
+OPTIONS_DEFINE= TEST
+
+CONFIGURE_ARGS= --disable-werror --without-docs
+CPPFLAGS+= -I${LOCALBASE}/include
+
+GNU_CONFIGURE= yes
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+TEST_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/cppunit.pc:${PORTSDIR}/devel/cppunit
+TEST_CONFIGURE_OFF= --disable-tests
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTEST}
+post-build:
+ @cd ${WRKSRC}/src/test && ${MAKE_CMD} check
+.endif
+
+.include <bsd.port.mk>