aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2014-02-14 16:57:27 +0000
committerMikhail Teterin <mi@FreeBSD.org>2014-02-14 16:57:27 +0000
commit14783492d94d257fc7e414ffc3bcc134bf28098d (patch)
tree0b036774147be0f98853e87e2b7ddb0ac30bc580 /graphics/libfpx
parentc8058284a4e555ca1cf648fc3fd37eed80d9a950 (diff)
downloadports-14783492d94d257fc7e414ffc3bcc134bf28098d.tar.gz
ports-14783492d94d257fc7e414ffc3bcc134bf28098d.zip
Upgrade from 1.3.1-3 to 1.3.1-4. The only real change (outside of the auto* nonsense) is the
restoration of the padding at the end of CDirEntry. Clang++ used to flag it as unused private field, which lead to its removal (incorrectly) -- and this new release from upstream restores the padding. It is still flagged by clang++ so a new patch attempts to suppress that.
Notes
Notes: svn path=/head/; revision=344284
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/Makefile3
-rw-r--r--graphics/libfpx/distinfo4
-rw-r--r--graphics/libfpx/files/patch-c++10
-rw-r--r--graphics/libfpx/files/patch-unused-padding15
4 files changed, 18 insertions, 14 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index a7c1ae746784..d48e0f35b730 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libfpx
-DISTVERSION= 1.3.1-3
+DISTVERSION= 1.3.1-4
CATEGORIES= graphics
MASTER_SITES= http://imagemagick.mirrorcatalogs.com/delegates/ \
http://www.imagemagick.org/download/delegates/ \
@@ -17,7 +17,6 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= Library routines for working with Flashpix images
USE_XZ= yes
-MAKE_JOBS_UNSAFE=yes
PLIST_FILES= lib/libfpx.so.2 lib/libfpx.so lib/libfpx.a include/fpxlib.h
USE_LDCONFIG= yes
diff --git a/graphics/libfpx/distinfo b/graphics/libfpx/distinfo
index 5addb7483768..9c8f14c5e323 100644
--- a/graphics/libfpx/distinfo
+++ b/graphics/libfpx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libfpx-1.3.1-3.tar.xz) = cb82d8d90a0f195abcb6c0f1dc4cf181e9569f8f28d96969ed8378938641847a
-SIZE (libfpx-1.3.1-3.tar.xz) = 1892860
+SHA256 (libfpx-1.3.1-4.tar.xz) = 638875039246e11a3646ca34c2c8f1f790c54aa00b878301bb127f30eeea7b5d
+SIZE (libfpx-1.3.1-4.tar.xz) = 1896560
diff --git a/graphics/libfpx/files/patch-c++ b/graphics/libfpx/files/patch-c++
deleted file mode 100644
index 691f7be32979..000000000000
--- a/graphics/libfpx/files/patch-c++
+++ /dev/null
@@ -1,10 +0,0 @@
---- oless/h/owchar.h 2013-09-03 13:38:08.000000000 -0400
-+++ oless/h/owchar.h 2013-09-11 18:31:34.000000000 -0400
-@@ -24,6 +24,6 @@
- #include <stdarg.h>
-
--
- #ifdef __cplusplus
-+#include <string>
- extern "C" {
- #endif
diff --git a/graphics/libfpx/files/patch-unused-padding b/graphics/libfpx/files/patch-unused-padding
new file mode 100644
index 000000000000..10ae881ec697
--- /dev/null
+++ b/graphics/libfpx/files/patch-unused-padding
@@ -0,0 +1,15 @@
+The padding is important (earlier versions tried to remove it leading to peril),
+but clang++ complains about it. Mark it as __unused to prevent that...
+--- oless/h/dir.hxx 2014-02-12 08:14:24.000000000 -0500
++++ oless/h/dir.hxx 2014-02-14 11:36:59.000000000 -0500
+@@ -142,5 +142,9 @@
+ inline void SetBitFlags(BYTE bValue, BYTE bMask);
+
+- BYTE _bpad[CBDIRPAD]; // do not remove, bad things will happen!
++ BYTE _bpad[CBDIRPAD] // do not remove, bad things will happen!
++#ifdef __clang__
++ __unused
++#endif
++ ;
+ };
+