aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-04-23 23:30:59 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-04-23 23:30:59 +0000
commit703b7fae0f513a4e3451c44232804aa8525cd79f (patch)
tree93000a5aecd28bada71969b55f704a8bf35d1468 /graphics/libfpx
parentb99956a2cdff57582a3f337b73b71d7f85806339 (diff)
downloadports-703b7fae0f513a4e3451c44232804aa8525cd79f.tar.gz
ports-703b7fae0f513a4e3451c44232804aa8525cd79f.zip
Upgrade from 1.2.0.4 to 1.2.0.7 released on April 12th. May need
careful testing on other architectures, though... Compelled by: Chris P.
Notes
Notes: svn path=/head/; revision=79544
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/Makefile7
-rw-r--r--graphics/libfpx/distinfo2
-rw-r--r--graphics/libfpx/files/Makefile.bsd8
-rw-r--r--graphics/libfpx/files/patch-basics::a_file.cpp16
4 files changed, 9 insertions, 24 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index c232d610c5f1..58f0aaf4e36e 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= libfpx
-PORTVERSION= 1.2.0.4
-PORTREVISION= 1
+PORTVERSION= 1.2.0.7
CATEGORIES= graphics
-MASTER_SITES= http://imagemagick.sourceforge.net/http/delegates/ \
- ftp://gd.tuwien.ac.at/pub/graphics/%SUBDIR%/ \
+MASTER_SITES= ftp://gd.tuwien.ac.at/pub/graphics/%SUBDIR%/ \
ftp://ftp.sunet.se/pub/multimedia/graphics/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/ImageMagick,} \
ftp://ftp.crc.ca/pub/packages/graphics/imagemagick/ \
@@ -34,6 +32,7 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
MAKE_ARGS+= -j2
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
+USE_BZIP2= yes
post-patch:
# Replacing references to <malloc.h> with <stdlib.h>
diff --git a/graphics/libfpx/distinfo b/graphics/libfpx/distinfo
index b697d71e209c..49d6093ea875 100644
--- a/graphics/libfpx/distinfo
+++ b/graphics/libfpx/distinfo
@@ -1 +1 @@
-MD5 (libfpx-1.2.0.4.tar.gz) = e74bc1ed5c9d912563bec5ae19ad4676
+MD5 (libfpx-1.2.0.7.tar.bz2) = 8f4dd8d6706562dcb0c7aeeb65d862fb
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index 528a8f1e99e9..b8418b96b359 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -1,14 +1,16 @@
LIB = fpx
INCS = fpxlib.h
SHLIB_MAJOR= 1
-SHLIB_MINOR= 2
+SHLIB_MINOR= 7
LIBDIR = ${LOCALBASE}/lib
INCSDIR = ${LOCALBASE}/include
INCDIR = ${INCSDIR} # for pre-bsd.incs.mk API
NOPROFILE= Don't want it
-CFLAGS+= -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1
+HAVES= -DHAVE_WCHAR_H -DHAVE_DLFCN_H \
+ -DHAVE_SYS_PARAM_H -DHAVE_SYS_MOUNT_H
+CFLAGS+= ${HAVES}
CPPS != find ${.CURDIR} -name \*.cpp -print
# Some of the .cxx files are #include-ed into others, so can't use `find' here:
@@ -24,7 +26,7 @@ CPPS += ${OLESS:S/^/${.CURDIR}\/oless\//} ${JPGS}
SRCS = ${CPPS:T}
-CXXFLAGS+= -fno-rtti -fno-exceptions -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1
+CXXFLAGS+= -fno-rtti -fno-exceptions ${HAVES}
LDADD += -L${LOCALBASE}/lib -ljpeg -lstdc++
.PATH: ${CPPS:H}
diff --git a/graphics/libfpx/files/patch-basics::a_file.cpp b/graphics/libfpx/files/patch-basics::a_file.cpp
deleted file mode 100644
index b0069f69d690..000000000000
--- a/graphics/libfpx/files/patch-basics::a_file.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- basics/a_file.cpp Sat Dec 23 17:10:00 2000
-+++ basics/a_file.cpp Thu Jan 18 11:37:44 2001
-@@ -29,4 +29,4 @@
- # include <sys/types.h>
-+# include <sys/uio.h>
- # include <sys/stat.h>
--# include <sys/statfs.h>
- # include <sys/ioctl.h>
---- basics/filename.cpp Sat Dec 23 17:10:00 2000
-+++ basics/filename.cpp Thu Jan 18 11:33:35 2001
-@@ -39,3 +39,4 @@
- # include <sys/stat.h>
--# include <sys/statfs.h>
-+# include <sys/param.h>
-+# include <sys/mount.h>
- # include <stdio.h>