aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2018-01-21 01:09:18 +0000
committerMikhail Teterin <mi@FreeBSD.org>2018-01-21 01:09:18 +0000
commitadfc6a946c36f60a595dc2efb83d8247c79f3c8f (patch)
treec9538385795dcc66ef4789a81673258694e78016 /graphics/libfpx
parent87c4e43124716d76844fa4eb0d97e1256211ef82 (diff)
downloadports-adfc6a946c36f60a595dc2efb83d8247c79f3c8f.tar.gz
ports-adfc6a946c36f60a595dc2efb83d8247c79f3c8f.zip
Upgrade from 1.3.1-4 to 1.3.1-10 (security fixes).
Resolve errors triggered on -current by the use of C++17 PR: 225299
Notes
Notes: svn path=/head/; revision=459561
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/Makefile3
-rw-r--r--graphics/libfpx/distinfo5
-rw-r--r--graphics/libfpx/files/Makefile.bsd7
-rw-r--r--graphics/libfpx/files/patch-null-casts25
4 files changed, 31 insertions, 9 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index 801ea17afbc0..eb9dc48d3b0b 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libfpx
-DISTVERSION= 1.3.1-4
-PORTREVISION= 1
+DISTVERSION= 1.3.1-10
CATEGORIES= graphics
MASTER_SITES= http://imagemagick.mirrorcatalogs.com/delegates/ \
http://www.imagemagick.org/download/delegates/ \
diff --git a/graphics/libfpx/distinfo b/graphics/libfpx/distinfo
index 9c8f14c5e323..aa5e7229d55a 100644
--- a/graphics/libfpx/distinfo
+++ b/graphics/libfpx/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libfpx-1.3.1-4.tar.xz) = 638875039246e11a3646ca34c2c8f1f790c54aa00b878301bb127f30eeea7b5d
-SIZE (libfpx-1.3.1-4.tar.xz) = 1896560
+TIMESTAMP = 1516495685
+SHA256 (libfpx-1.3.1-10.tar.xz) = 491b55535580d27355669c45fe995446bd34df5dbcdc15312e58c3ebecc6a455
+SIZE (libfpx-1.3.1-10.tar.xz) = 1907580
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index 62483f7c88c9..7565642489e7 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -8,12 +8,11 @@ LIBDIR = ${PREFIX}/lib
INCSDIR = ${PREFIX}/include
INCDIR = ${INCSDIR} # for pre-bsd.incs.mk API
-NO_PROFILE= Don't want it
-NOPROFILE= ${NO_PROFILE}
+MK_PROFILE= no
HAVES= -DHAVE_WCHAR_H -DHAVE_DLFCN_H \
-DHAVE_SYS_TIME_H \
-DHAVE_SYS_PARAM_H -DHAVE_SYS_MOUNT_H
-CFLAGS+= ${HAVES}
+CFLAGS+= ${HAVES} -Dregister=
CPPS != find ${.CURDIR} -name \*.cpp -print
# Some of the .cxx files are #include-ed into others, so can't use `find' here:
@@ -23,7 +22,7 @@ OLESS := ascii.cxx cdocfile.cxx chinst.cxx dffuncs.cxx dfiter.cxx \
iter.cxx mem.cxx msf.cxx msfiter.cxx mstream.cxx page.cxx \
refilb.cxx rexpdf.cxx sstream.cxx storage.cxx time.cxx \
vect.cxx wchar.c
-JPGS != find ${.CURDIR}/jpeg -name \*.c
+JPGS != find ${.CURDIR}/jpeg -name \*.c -not -name dllmain.c
CPPS += ${OLESS:S/^/${.CURDIR}\/oless\//} ${JPGS}
diff --git a/graphics/libfpx/files/patch-null-casts b/graphics/libfpx/files/patch-null-casts
index 918be6db3c39..d09109fefd34 100644
--- a/graphics/libfpx/files/patch-null-casts
+++ b/graphics/libfpx/files/patch-null-casts
@@ -1,5 +1,5 @@
--- oless/expdf.cxx 2013-09-02 11:47:00.000000000 -0400
-+++ oless/expdf.cxx 2014-02-14 14:29:24.000000000 -0500
++++ oless/expdf.cxx 2018-01-20 19:59:14.495701000 -0500
@@ -610,5 +610,5 @@
olErr(EH_Err, STG_E_INVALIDFUNCTION);
olChk(Validate());
@@ -21,3 +21,26 @@
+ 0, &pstmsrc));
// It's a stream
+@@ -1575,5 +1575,5 @@
+ olMemTo(EH_pst, pstExp = new CExposedStream());
+ olChkTo(EH_pstExp, pstExp->Init(pstDirect, this,
+- df, pdfnName, (ULONG)NULL));
++ df, pdfnName, 0));
+ *ppStream = pstExp;
+ return S_OK;
+@@ -1624,5 +1624,5 @@
+ olMemTo(EH_pst, pstExp = new CExposedStream());
+ olChkTo(EH_pstExp, pstExp->Init(pstDirect, this,
+- df, pdfnName, (ULONG)NULL));
++ df, pdfnName, 0));
+ *ppStream = pstExp;
+ return S_OK;
+--- oless/storage.cxx 2013-09-02 11:47:00.000000000 -0400
++++ oless/storage.cxx 2018-01-20 20:03:24.664133000 -0500
+@@ -144,5 +144,5 @@
+
+ olChk(ValidateNameW(pwcsName, CBMAXPATHCOMPLEN));
+- olMem(pilb = new CFileILB(pwcsName, (DWORD)NULL, FALSE));
++ olMem(pilb = new CFileILB(pwcsName, 0, FALSE));
+ olChk(pilb->Open(STGM_READ));
+ sc = GetScode( StgIsStorageILockBytes(pilb) );