aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-07-14 03:46:35 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-07-14 03:46:35 +0000
commitdcc15d3af681e80d10eb2ce13bfc6014eb652562 (patch)
tree231b812dc391885f7a0b3ce496730708edb650a4 /graphics/libfpx
parenta2d1c8cccf199a909bf00ca92a819bf62dd1c3ae (diff)
downloadports-dcc15d3af681e80d10eb2ce13bfc6014eb652562.tar.gz
ports-dcc15d3af681e80d10eb2ce13bfc6014eb652562.zip
Upgrade to 1.2.0.9. All our patches are in now...
PR: 53595 Submitted by: Melvyn Sopacua
Notes
Notes: svn path=/head/; revision=84846
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/Makefile2
-rw-r--r--graphics/libfpx/distinfo2
-rw-r--r--graphics/libfpx/files/Makefile.bsd1
-rw-r--r--graphics/libfpx/files/patch-buffdesc87
-rw-r--r--graphics/libfpx/files/patch-ole::gen_guid.cpp7
-rw-r--r--graphics/libfpx/files/patch-types54
-rw-r--r--graphics/libfpx/files/patch-zero-size187
7 files changed, 3 insertions, 337 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index d4faca475cc2..ec4678678597 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libfpx
-PORTVERSION= 1.2.0.8
+PORTVERSION= 1.2.0.9
CATEGORIES= graphics
MASTER_SITES= ftp://gd.tuwien.ac.at/pub/graphics/%SUBDIR%/ \
ftp://ftp.sunet.se/pub/multimedia/graphics/%SUBDIR%/ \
diff --git a/graphics/libfpx/distinfo b/graphics/libfpx/distinfo
index 3918a441f70c..124b229e0e23 100644
--- a/graphics/libfpx/distinfo
+++ b/graphics/libfpx/distinfo
@@ -1 +1 @@
-MD5 (libfpx-1.2.0.8.tar.bz2) = c926fc8d450be7a2a6337f75d39d83a0
+MD5 (libfpx-1.2.0.9.tar.bz2) = aa9a74dbcacbd5884c9aa3d4c97f9db7
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index b8418b96b359..893633927b76 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -9,6 +9,7 @@ INCDIR = ${INCSDIR} # for pre-bsd.incs.mk API
NOPROFILE= Don't want it
HAVES= -DHAVE_WCHAR_H -DHAVE_DLFCN_H \
+ -DHAVE_SYS_TIME_H \
-DHAVE_SYS_PARAM_H -DHAVE_SYS_MOUNT_H
CFLAGS+= ${HAVES}
diff --git a/graphics/libfpx/files/patch-buffdesc b/graphics/libfpx/files/patch-buffdesc
deleted file mode 100644
index b503e370e7ce..000000000000
--- a/graphics/libfpx/files/patch-buffdesc
+++ /dev/null
@@ -1,87 +0,0 @@
---- fpx/buffdesc.cpp Wed Apr 23 21:31:48 2003
-+++ fpx/buffdesc.cpp Fri Apr 25 18:41:02 2003
-@@ -74,69 +74,31 @@
- }
- }
--/*
--// Rotate on the left by 8 bits on each 32 bits long and wrap the last one
--static void Shift8BitsLeft (unsigned char* buffer, long size)
--{
-- register unsigned long tmp;
-- register unsigned long* all = (unsigned long*)(buffer);
-- while (size--) {
-- tmp = (*all) >> 24;
-- (*all) = ((*all) << 8) | tmp;
-- all++;
-- }
--} */
-+
- //Updated the procedure to work on both architedture --**IM-05/16/97
- // Rotate on the left by 8 bits on each 32 bits long and wrap the last one
- static void Shift8BitsLeft (unsigned char* buffer, long size)
- {
-- register unsigned long tmp;
-- register unsigned long* all = (unsigned long*)(buffer);
-+ unsigned char tmp;
- while (size--) {
--
--#ifdef IN_LITTLE_ENDIAN
-- *all = (unsigned long) SwapBytes( (int32) *all );
--#endif
--
-- tmp = (*all) >> 24;
-- (*all) = ((*all) << 8) | tmp;
--
--#ifdef IN_LITTLE_ENDIAN
-- *all = (unsigned long) SwapBytes( (int32) *all );
--#endif
--
-- all++;
-+ tmp = buffer[0];
-+ buffer[0] = buffer[1];
-+ buffer[1] = buffer[2];
-+ buffer[2] = buffer[3];
-+ buffer[3] = tmp;
-+ buffer += 4;
- }
- }
--/*
--// Rotate on the right by 8 bits on each 32 bits long and wrap the last one
--static void Shift8BitsRight (unsigned char* buffer, long size)
--{
-- register unsigned long tmp;
-- register unsigned long* all = (unsigned long*)(buffer);
-- while (size--) {
-- tmp = (*all) << 24;
-- (*all) = ((*all) >> 8) | tmp;
-- all++;
-- }
--}
--*/
-
- // Rotate on the right by 8 bits on each 32 bits long and wrap the last one
- static void Shift8BitsRight (unsigned char* buffer, long size)
- {
-- register unsigned long tmp;
-- register unsigned long* all = (unsigned long*)(buffer);
-+ unsigned char tmp;
- while (size--) {
--
--#ifdef IN_LITTLE_ENDIAN
-- *all = (unsigned long) SwapBytes( (int32) *all );
--#endif
-- tmp = (*all) << 24;
-- (*all) = ((*all) >> 8) | tmp;
--
--#ifdef IN_LITTLE_ENDIAN
-- *all = (unsigned long) SwapBytes( (int32) *all );
--#endif
-- all++;
-+ tmp = buffer[3];
-+ buffer[3] = buffer[2];
-+ buffer[2] = buffer[1];
-+ buffer[1] = buffer[0];
-+ buffer[0] = tmp;
-+ buffer += 4;
- }
- }
diff --git a/graphics/libfpx/files/patch-ole::gen_guid.cpp b/graphics/libfpx/files/patch-ole::gen_guid.cpp
deleted file mode 100644
index 9f5e1a9cd5db..000000000000
--- a/graphics/libfpx/files/patch-ole::gen_guid.cpp
+++ /dev/null
@@ -1,7 +0,0 @@
---- ole/gen_guid.cpp Sat Dec 23 17:12:09 2000
-+++ ole/gen_guid.cpp Thu Jan 18 11:46:44 2001
-@@ -55,2 +55,4 @@
- } timespec;
-+#else
-+# include <sys/time.h>
- #endif
diff --git a/graphics/libfpx/files/patch-types b/graphics/libfpx/files/patch-types
deleted file mode 100644
index 8ff4b0c73dd7..000000000000
--- a/graphics/libfpx/files/patch-types
+++ /dev/null
@@ -1,54 +0,0 @@
---- basics/b_string.cpp Sat Dec 23 14:37:48 2000
-+++ basics/b_string.cpp Thu Nov 7 06:07:53 2002
-@@ -345,10 +345,10 @@
-
- // Copy unmodified start of string *this
-- nbUnchangedStartingChars = foundStr - Texte();
-+ nbUnchangedStartingChars = foundStr - (const char*)Texte();
- strncpy(modifiedStr, (const char*)Texte(), nbUnchangedStartingChars);
- modifiedStr[nbUnchangedStartingChars] = '\0';
-
- // Replace "^i" by replaceStr
-- strcat(modifiedStr, replaceStr.Texte());
-+ strcat(modifiedStr, (const char*)replaceStr.Texte());
-
- // Copy unmodified end of string *this
---- basics/mac_comp.h Sat Dec 23 14:37:48 2000
-+++ basics/mac_comp.h Thu Nov 7 06:21:10 2002
-@@ -29,4 +29,5 @@
- #endif
-
-+ #include <sys/types.h>
- #include <memory.h>
- #include <string.h>
-@@ -67,5 +68,5 @@
- ConstStr27Param,ConstStr15Param;
-
-- typedef unsigned long OSType;
-+ typedef intptr_t OSType;
- typedef OSType *OSTypePtr;
-
---- ri_image/priimage.h Sat Dec 23 14:37:49 2000
-+++ ri_image/priimage.h Thu Nov 7 06:31:12 2002
-@@ -163,9 +164,9 @@
-
- void ResetMagicNumber() { magicNumber = 0; }
-- void SetMagicNumber() { magicNumber = (unsigned long)(this); }
-- Boolean ChallengeMagicNumber() { return (magicNumber == (unsigned long)(this)); }
-- void SetMagicNumber(unsigned long id) { magicNumber = id; }
-- Boolean ChallengeMagicNumber(unsigned long id) { return (magicNumber == id); }
-- unsigned long GetMagicNumber() { return magicNumber; }
-+ void SetMagicNumber() { magicNumber = (intptr_t)(this); }
-+ Boolean ChallengeMagicNumber() { return (magicNumber == (intptr_t)(this)); }
-+ void SetMagicNumber(intptr_t id) { magicNumber = id; }
-+ Boolean ChallengeMagicNumber(intptr_t id) { return (magicNumber == id); }
-+ intptr_t GetMagicNumber() { return magicNumber; }
- protected:
- // Protected interface: Methods used by the derived classes to customize the behavior of a RI Image:
-@@ -215,5 +216,5 @@
-
- // Reference management
-- unsigned long magicNumber; // Used to reference a PRIImage object used by several composition objects
-+ intptr_t magicNumber; // Used to reference a PRIImage object used by several composition objects
- long nbRefs; // Number of existing references to this PRIImage object
-
diff --git a/graphics/libfpx/files/patch-zero-size b/graphics/libfpx/files/patch-zero-size
deleted file mode 100644
index a1cfb3d561ec..000000000000
--- a/graphics/libfpx/files/patch-zero-size
+++ /dev/null
@@ -1,187 +0,0 @@
---- oless/h/page.hxx Sat Dec 23 17:37:48 2000
-+++ oless/h/page.hxx Fri Apr 25 12:43:54 2003
-@@ -60,5 +60,5 @@
- inline ULONG GetOffset(void) const;
- inline SECT GetSect(void) const;
-- inline void *GetData(void) const;
-+ inline BYTE *GetData(void) const;
- inline DWORD GetFlags(void) const;
- inline CPagedVector * GetVector(void) const;
-@@ -92,19 +92,4 @@
- DWORD _dwFlags;
- LONG _cReferences;
--
--#ifdef _MSC_VER
-- // disable compiler warning C4200: nonstandard extension used :
-- // zero-sized array in struct/union
--#pragma warning(disable: 4200)
-- BYTE _ab[0];
--#pragma warning(default: 4200)
--#else
--# ifdef __GNUC__
-- BYTE _ab[0];
--# else
-- // FIXME: brain damage
-- BYTE* _ab;
--# endif
--#endif
- };
-
-@@ -234,7 +219,7 @@
- //----------------------------------------------------------------------------
-
--inline void * CMSFPage::GetData(void) const
-+inline BYTE * CMSFPage::GetData(void) const
- {
-- return (void *) _ab;
-+ return ((BYTE *)this) + sizeof(CMSFPage);
- }
-
---- oless/h/dir.hxx Wed Apr 23 22:20:35 2003
-+++ oless/h/dir.hxx Fri Apr 25 16:39:34 2003
-@@ -167,18 +167,13 @@
-
- private:
--#ifdef _MSC_VER
--#pragma warning(disable: 4200)
-- CDirEntry _adeEntry[];
--#pragma warning(default: 4200)
--#else
--# ifdef __GNUC__
-- CDirEntry _adeEntry[0];
--# else
-- // FIXME: braindamage
-- CDirEntry* _adeEntry;
--# endif
--#endif
--
-+ // GetEntries() relies on the fact, there are no data
-+ // fields in the class...
-+ inline CDirEntry* GetEntries(void) const;
- };
-+
-+inline CDirEntry * CDirSect::GetEntries(void) const
-+{
-+ return (CDirEntry *)this;
-+}
-
- //+-------------------------------------------------------------------------
---- oless/h/fat.hxx Sat Dec 23 17:37:48 2000
-+++ oless/h/fat.hxx Fri Apr 25 16:35:20 2003
-@@ -51,23 +51,18 @@
- inline void ByteSwap(USHORT cbSector);
-
--private:
--
--#ifdef _MSC_VER
--#pragma warning(disable: 4200)
-- SECT _asectEntry[];
--#pragma warning(default: 4200)
--#else
--# ifdef __GNUC__
-- SECT _asectEntry[0];
--# else
--// FIXME: brain damage
-- SECT* _asectEntry;
--# endif
--#endif
-+private:
-+ // GetSects() relies on the fact, that the class has no
-+ // data fields...
-+ inline SECT * GetSects(void) const;
- };
-
-+inline SECT * CFatSect::GetSects(void) const
-+{
-+ return (SECT *)this;
-+}
-+
- inline SECT CFatSect::GetSect(const FSOFFSET sect) const
- {
-- return _asectEntry[sect];
-+ return GetSects()[sect];
- }
-
-@@ -75,15 +70,15 @@
- const SECT sectNew)
- {
-- _asectEntry[sect] = sectNew;
-+ GetSects()[sect] = sectNew;
- }
-
- inline SECT CFatSect::GetNextFat(USHORT uSize) const
- {
-- return _asectEntry[uSize];
-+ return GetSects()[uSize];
- }
-
- inline void CFatSect::SetNextFat(USHORT uSize, const SECT sect)
- {
-- _asectEntry[uSize] = sect;
-+ GetSects()[uSize] = sect;
- }
-
-@@ -92,5 +87,5 @@
- // swap all sectors in the sector
- for (FSOFFSET i=0; i < cbSector; i++)
-- ::ByteSwap(&(_asectEntry[i]));
-+ ::ByteSwap(GetSects() + i);
- }
-
---- oless/h/dirfunc.hxx Sat Dec 23 17:37:48 2000
-+++ oless/h/dirfunc.hxx Fri Apr 25 13:55:34 2003
-@@ -168,5 +168,5 @@
- inline CDirEntry* CDirSect::GetEntry(DIROFFSET iEntry)
- {
-- return &(_adeEntry[iEntry]);
-+ return GetEntries() + iEntry;
- }
-
-@@ -207,5 +207,5 @@
- {
- for (unsigned int i=0; i< (cbSector/sizeof(CDirEntry)); i++)
-- _adeEntry[i].ByteSwap();
-+ GetEntries()[i].ByteSwap();
- }
-
---- oless/fat.cxx Thu Nov 14 18:45:51 2002
-+++ oless/fat.cxx Fri Apr 25 13:43:19 2003
-@@ -38,5 +38,5 @@
-
- //This assumes that FREESECT is always 0xFFFFFFFF
-- memset(_asectEntry, 0xFF, uEntries * sizeof(SECT));
-+ memset(GetSects(), 0xFF, uEntries * sizeof(SECT));
-
- msfDebugOut((DEB_FAT,"Out CFatSect constructor\n"));
-@@ -68,5 +68,5 @@
- msfDebugOut((DEB_FAT,"Sector size is %u sectors\n",uSize));
-
-- memcpy(_asectEntry,fsOld._asectEntry,sizeof(SECT)*uSize);
-+ memcpy(GetSects(),fsOld.GetSects(),sizeof(SECT)*uSize);
- msfDebugOut((DEB_FAT,"Out CFatSect copy constructor\n"));
- return S_OK;
---- oless/dir.cxx Thu Nov 14 18:45:51 2002
-+++ oless/dir.cxx Fri Apr 25 13:53:12 2003
-@@ -152,5 +152,5 @@
- for (ULONG i = 0; i < cdeEntries; i++)
- {
-- _adeEntry[i].Init(STGTY_INVALID);
-+ GetEntries()[i].Init(STGTY_INVALID);
- }
-
---- oless/page.cxx Thu Nov 14 18:45:51 2002
-+++ oless/page.cxx Fri Apr 25 12:53:03 2003
-@@ -39,5 +39,5 @@
- {
- case SIDDIR:
-- ((CDirSect *)_ab)->
-+ ((CDirSect *)GetData())->
- ByteSwap( ((CDirVector*)pVect)->GetSectorSize() );
- break;
-@@ -45,5 +45,5 @@
- case SIDMINIFAT:
- case SIDDIF:
-- ((CFatSect *)_ab)->
-+ ((CFatSect *)GetData())->
- ByteSwap( ((CFatVector*)pVect)->GetSectBlock() );
- break;